Workbench User Guide
  Eclipse platform overview
  Getting started
    Basic tutorial
      The Workbench
      Editors and views
        Editors
        Views
      A simple project
        Using the File menu
        Using the popup
        Using the New button
      Closing an editor
      Navigating resources
        Opening resources in the Project Explorer
        Go To
      Files
      Exporting files
      Importing files
        Drag and drop or copy and paste
        Import wizard
      Deleting resources
      Working with other editors
        External editors
        Embedded editors
        Editing files outside the Workbench
      Copying, renaming and moving
        Copying
        Renaming
        Moving
      Searching
        Starting a search
        The Search view
      Tasks and markers
        Unassociated tasks
        Associated tasks
        Opening files
      Bookmarks
        Adding and viewing bookmarks
        Using bookmarks
        Removing bookmarks
      Rearranging views and editors
        Rearranging views
        Tiling editors
        Rearranging tabbed views
        Maximizing and minimizing
      Perspectives
        New perspectives
        New windows
        Saving perspectives
        Turning menu and tool bar items on and off
      Comparing
        Simple compare
        Understanding the comparison
        Working with the comparison
      Local history
      Responsive UI
      Exiting the Workbench
    Team CVS tutorial
      Setting up a CVS repository
      Starting offline
      Sharing the project
        Specifying a repository location
        Repository locations
        Sharing a project
      Working with another user
        Checking out a project
        Another user making changes
        Making our own changes
        Working with conflicting changes
        Replacing
        Versioning your project
        A quick review
      Working with CVS History
    Ant & external tools tutorial
      Eclipse Ant basics
        Creating Ant buildfiles
        Editing Ant buildfiles
        Running Ant buildfiles
        Saving & Reusing Ant options
        Using the Ant view
      Ant buildfiles as project builders
        Creating a project builder Ant buildfile
        Executing project builders
        Project Builder Ant Targets
      External tools
        Non-Ant project builders
        Stand-alone external tools
  Concepts
    Welcome
    Workbench
      Resources
      Resource hierarchies
      Linked resources
      Virtual folders
      Path variables
      Resource filters
      Working sets
      Builds
      Local history
    Perspectives
    Editors
      Ant Editor
      External editors
    Views
      Detached views
      Ant view
      Project Explorer view
      Help view
      Tasks view
      Problems view
      Outline view
      Properties view
      Search view
    Toolbars
    Markers
    Bookmarks
    Label decorations
    Help
    Ant & External tools
      Ant support
      External tools
    Team programming with CVS
      Versions
      Branches
      CVS Repositories
      Three way comparisons
      Synchronizing with a CVS repository
      Watch/Edit
    Accessibility features in Eclipse
      Navigating the user interface using the keyboard
      Accessibility features in textual editors
      Fonts and colors in Eclipse
    Features
  Tasks
    Running Eclipse
    Upgrading Eclipse
    Working with perspectives
      Switching between perspectives
      Specifying the default perspective
      Opening perspectives
      Changing where perspectives open
      Showing and hiding menu items and toolbar buttons
      Configuring the menu and toolbar of the perspective
      Configuring perspective shortcuts
      Saving a user defined perspective
      Deleting a user defined perspective
      Resetting perspectives
    Working with views and editors
      Opening views
      Moving and docking views
      Rearranging tabbed views
      Detaching views and editors
      Opening files for editing
      Associating editors with file types
      Editing files outside the Workbench
      Tiling editors
      Maximizing and minimizing in the eclipse presentation
    Customizing the Workbench
      Customizing welcome
        Customize Welcome Dialog
      Rearranging the main toolbar
      Changing the key bindings
      Changing fonts and colors
      Controlling single and double click behavior
      Importing and exporting preferences
    Working with projects, folders and files
      Creating a project
      Closing projects
      Deleting projects
      Creating a folder
      Creating a file
      Creating linked resources
      Creating virtual folders
      Moving resources
      Copying resources
      Renaming resources
      Deleting resources
      Viewing resources properties
      Creating resource filters
    Navigating and finding resources
      Finding a resource quickly
      Searching for files
      Searching for text within a file
      Showing or hiding files in the Project Explorer view
      Linking the Project Explorer view to the active editor
    Problems, bookmarks, tasks and other markers
      Creating a bookmark within a file
      Creating a bookmark for an entire file
      Deleting a bookmark
      Adding line items in the Tasks view
      Associating a task with a resource
      Deleting tasks
      Filtering the Tasks and Problems views
      Automatically fixing problems
    Comparing resources
      Setting preferences for comparing files
      Understanding the comparison
      Merging changes in the compare editor
    Working with local history
      Comparing resources with the local history
      Replacing a resource with local history
      Restoring deleted resources from local history
      Setting local history preferences
    Importing
      Importing existing projects
      Importing resources from the file system
      Importing resources from an Archive file
    Exporting
      Exporting resources to the file system
      Exporting resources to an Archive file
    Building resources
      Performing builds automatically
      Performing builds manually
      Saving resources automatically before a manual build
      Changing build order
    Running Ant buildfiles
      Modifying the Ant classpath
      Using a different version of Ant
      Adding new Ant tasks and types
    Running external tools
    Accessing help
      Navigating help topics
      Searching help
      Using help scopes
      Accessing context-sensitive help
      Help display settings
      Help accessibility
    Working in the team environment with CVS
      Working with a CVS repository
        Creating a CVS repository location
        Connecting and configuring CVS with SSH
        Password Management
        Discarding a CVS repository location
        Refreshing the CVS Repositories View
        Discovering branch and version tags
        Changing the properties of a CVS repository location
        Changing the encoding of a CVS repository location
        Setting the content type of a file extension
      Working with projects shared with CVS
        Enabling the CVS resource decorations
        Sharing a new project using CVS
        Project checked out with another CVS tool
        Checking out a project from a CVS repository
        Checking out a module from a CVS repository
        Checking out a folder into an existing project
        Disconnecting a project from CVS
        Setting the CVS keyword substitution mode
        Filtering CVS Revisions in the History view
        Changing the sharing of a project
        Sharing your workspace setup using Project Sets
      Synchronizing with the repository
        Updating
        Committing
        Version control life cycle: adding and ignoring resources
          Creating a global ignore pattern
          Authoring the CVS .cvsignore file
          Overriding or removing resource ignore patterns
        Resolving conflicts
        Branching
        Merging from a branch
        Viewing a file's revision history
      Versioning
        Creating a version of a project
        Versioning projects in the repository
      Comparing resources with repository versions
      Working with patches
      Replacing resources in the workbench
      Finding out who's working on what: watch/edit
      Determining who last modified a line with the Annotate command
      Quick Diff: Showing changes in a text editor
      Changing CVS team settings
      Restoring deleted files from the repository
      Reverting a branch to a previous version
      Moving version tags
      Running the CVS command-line client outside of Eclipse
    Updating and installing software
      Updating the installation
      Installing new software
      Updating software using the Available Updates wizard
      Uninstalling software
      Installation Details
        Installation Details for Plug-ins
        Installation Details for Features
        Installation Details for the Configuration
      Adding a new software site
      Working with the Available Software sites
      Reverting to a previous install configuration
      Scheduling automatic updates
  Reference
    Minimizing data loss from crashes
    Preferences
      Accessibility
      Annotations
      Ant
      Ant Content Assist
      Ant Editor
      Ant Formatter
      Ant Runtime
      Ant Templates
      Appearance
      Automatic Updates
      Available Software Sites
      Build Order
      Capabilities
      Colors and Fonts
      Compare/Patch
      Content Types
      CVS
      CVS Annotate
      CVS Comment Templates
      CVS Console
      CVS Ext Connection Method
      CVS Label Decorations
      CVS Synchronize/Compare
      CVS Update/Merge
      CVS Watch/Edit
      Editors
      External Tools
      File Associations
      General
      Globalization
      Help
      Help Content
      Install/Update
      Keys
      Label Decorations
      Linked Resources
      Local History
      Network Connections
      Perspectives
      Quick Diff
      Search
      Secure Storage
      Spelling
      SSH2
      Startup and Shutdown
      Team
      Team File Content
      Team Ignored Resources
      Team Models
      Text Editors
      Tracing
      UI Responsiveness Monitoring
      Web Browser
      Workspace
      Workspaces
    Team support with CVS
      CVS
      CVS Checkout wizard
      CVS Console
      CVS History view
      CVS Repositories view
      CVS Workspace Synchronization
      CVS Merge Synchronization
      Merge wizard
      Add CVS Repository wizard
      CVS Sharing wizard
      CVS Label Decorations
      Ignoring resources from version control
    Secure storage
      How secure storage works
      Password recovery
      Life of a master password
      Secure storage runtime options
    User interface information
      Development environment
        Workbench toolbar
        Perspective Bar
        View toolbars
        Builds
        Perspectives
        Local history
        List of key bindings
        Switching workspaces
      Views and editors
        Workbench window layout
        Editor area
        Compare editor
        Search view
        Project Explorer view
        Bookmarks view
        Properties view
        Outline view
        CVS views
        Tasks view
        Problems view
        Ant editor
        Ant view
        Error Log view
      Wizards
        New Project wizard
        New Folder wizard
        New File wizard
        CVS Wizards
        Import wizard
        Export wizard
      Help contents
        Workbench User Guide
        Working with cheat sheets
          Working with composite cheat sheets
      Search
        File search
        Open Resource dialog
      Workbench menus
        File menu
        Edit menu
        Navigate menu
        Project menu
        Window menu
        Help menu
      Icons and buttons
        Project Explorer view icons
        Editor area marker bar
        Tasks view
        Toolbar buttons
        External Tools and Ant Icons
  Tips and tricks
    Workbench
    Editing
    Ant
    Help
    Team - CVS
  What's new
    Editors
    Debug
    Views, Dialogs and Toolbar
    Preferences
    Themes and Styling
    General Updates
  Legal
  Eclipse platform overview
  Getting started
    Basic tutorial
      The Workbench
      Editors and views
        Editors
        Views
      A simple project
        Using the File menu
        Using the popup
        Using the New button
      Closing an editor
      Navigating resources
        Opening resources in the Project Explorer
        Go To
      Files
      Exporting files
      Importing files
        Drag and drop or copy and paste
        Import wizard
      Deleting resources
      Working with other editors
        External editors
        Embedded editors
        Editing files outside the Workbench
      Copying, renaming and moving
        Copying
        Renaming
        Moving
      Searching
        Starting a search
        The Search view
      Tasks and markers
        Unassociated tasks
        Associated tasks
        Opening files
      Bookmarks
        Adding and viewing bookmarks
        Using bookmarks
        Removing bookmarks
      Rearranging views and editors
        Rearranging views
        Tiling editors
        Rearranging tabbed views
        Maximizing and minimizing
      Perspectives
        New perspectives
        New windows
        Saving perspectives
        Turning menu and tool bar items on and off
      Comparing
        Simple compare
        Understanding the comparison
        Working with the comparison
      Local history
      Responsive UI
      Exiting the Workbench
    Team CVS tutorial
      Setting up a CVS repository
      Starting offline
      Sharing the project
        Specifying a repository location
        Repository locations
        Sharing a project
      Working with another user
        Checking out a project
        Another user making changes
        Making our own changes
        Working with conflicting changes
        Replacing
        Versioning your project
        A quick review
      Working with CVS History
    Ant & external tools tutorial
      Eclipse Ant basics
        Creating Ant buildfiles
        Editing Ant buildfiles
        Running Ant buildfiles
        Saving & Reusing Ant options
        Using the Ant view
      Ant buildfiles as project builders
        Creating a project builder Ant buildfile
        Executing project builders
        Project Builder Ant Targets
      External tools
        Non-Ant project builders
        Stand-alone external tools
  Concepts
    Welcome
    Workbench
      Resources
      Resource hierarchies
      Linked resources
      Virtual folders
      Path variables
      Resource filters
      Working sets
      Builds
      Local history
    Perspectives
    Editors
      Ant Editor
      External editors
    Views
      Detached views
      Ant view
      Project Explorer view
      Help view
      Tasks view
      Problems view
      Outline view
      Properties view
      Search view
    Toolbars
    Markers
    Bookmarks
    Label decorations
    Help
    Ant & External tools
      Ant support
      External tools
    Team programming with CVS
      Versions
      Branches
      CVS Repositories
      Three way comparisons
      Synchronizing with a CVS repository
      Watch/Edit
    Accessibility features in Eclipse
      Navigating the user interface using the keyboard
      Accessibility features in textual editors
      Fonts and colors in Eclipse
    Features
  Tasks
    Running Eclipse
    Upgrading Eclipse
    Working with perspectives
      Switching between perspectives
      Specifying the default perspective
      Opening perspectives
      Changing where perspectives open
      Showing and hiding menu items and toolbar buttons
      Configuring the menu and toolbar of the perspective
      Configuring perspective shortcuts
      Saving a user defined perspective
      Deleting a user defined perspective
      Resetting perspectives
    Working with views and editors
      Opening views
      Moving and docking views
      Rearranging tabbed views
      Detaching views and editors
      Opening files for editing
      Associating editors with file types
      Editing files outside the Workbench
      Tiling editors
      Maximizing and minimizing in the eclipse presentation
    Customizing the Workbench
      Customizing welcome
        Customize Welcome Dialog
      Rearranging the main toolbar
      Changing the key bindings
      Changing fonts and colors
      Controlling single and double click behavior
      Importing and exporting preferences
    Working with projects, folders and files
      Creating a project
      Closing projects
      Deleting projects
      Creating a folder
      Creating a file
      Creating linked resources
      Creating virtual folders
      Moving resources
      Copying resources
      Renaming resources
      Deleting resources
      Viewing resources properties
      Creating resource filters
    Navigating and finding resources
      Finding a resource quickly
      Searching for files
      Searching for text within a file
      Showing or hiding files in the Project Explorer view
      Linking the Project Explorer view to the active editor
    Problems, bookmarks, tasks and other markers
      Creating a bookmark within a file
      Creating a bookmark for an entire file
      Deleting a bookmark
      Adding line items in the Tasks view
      Associating a task with a resource
      Deleting tasks
      Filtering the Tasks and Problems views
      Automatically fixing problems
    Comparing resources
      Setting preferences for comparing files
      Understanding the comparison
      Merging changes in the compare editor
    Working with local history
      Comparing resources with the local history
      Replacing a resource with local history
      Restoring deleted resources from local history
      Setting local history preferences
    Importing
      Importing existing projects
      Importing resources from the file system
      Importing resources from an Archive file
    Exporting
      Exporting resources to the file system
      Exporting resources to an Archive file
    Building resources
      Performing builds automatically
      Performing builds manually
      Saving resources automatically before a manual build
      Changing build order
    Running Ant buildfiles
      Modifying the Ant classpath
      Using a different version of Ant
      Adding new Ant tasks and types
    Running external tools
    Accessing help
      Navigating help topics
      Searching help
      Using help scopes
      Accessing context-sensitive help
      Help display settings
      Help accessibility
    Working in the team environment with CVS
      Working with a CVS repository
        Creating a CVS repository location
        Connecting and configuring CVS with SSH
        Password Management
        Discarding a CVS repository location
        Refreshing the CVS Repositories View
        Discovering branch and version tags
        Changing the properties of a CVS repository location
        Changing the encoding of a CVS repository location
        Setting the content type of a file extension
      Working with projects shared with CVS
        Enabling the CVS resource decorations
        Sharing a new project using CVS
        Project checked out with another CVS tool
        Checking out a project from a CVS repository
        Checking out a module from a CVS repository
        Checking out a folder into an existing project
        Disconnecting a project from CVS
        Setting the CVS keyword substitution mode
        Filtering CVS Revisions in the History view
        Changing the sharing of a project
        Sharing your workspace setup using Project Sets
      Synchronizing with the repository
        Updating
        Committing
        Version control life cycle: adding and ignoring resources
          Creating a global ignore pattern
          Authoring the CVS .cvsignore file
          Overriding or removing resource ignore patterns
        Resolving conflicts
        Branching
        Merging from a branch
        Viewing a file's revision history
      Versioning
        Creating a version of a project
        Versioning projects in the repository
      Comparing resources with repository versions
      Working with patches
      Replacing resources in the workbench
      Finding out who's working on what: watch/edit
      Determining who last modified a line with the Annotate command
      Quick Diff: Showing changes in a text editor
      Changing CVS team settings
      Restoring deleted files from the repository
      Reverting a branch to a previous version
      Moving version tags
      Running the CVS command-line client outside of Eclipse
    Updating and installing software
      Updating the installation
      Installing new software
      Updating software using the Available Updates wizard
      Uninstalling software
      Installation Details
        Installation Details for Plug-ins
        Installation Details for Features
        Installation Details for the Configuration
      Adding a new software site
      Working with the Available Software sites
      Reverting to a previous install configuration
      Scheduling automatic updates
  Reference
    Minimizing data loss from crashes
    Preferences
      Accessibility
      Annotations
      Ant
      Ant Content Assist
      Ant Editor
      Ant Formatter
      Ant Runtime
      Ant Templates
      Appearance
      Automatic Updates
      Available Software Sites
      Build Order
      Capabilities
      Colors and Fonts
      Compare/Patch
      Content Types
      CVS
      CVS Annotate
      CVS Comment Templates
      CVS Console
      CVS Ext Connection Method
      CVS Label Decorations
      CVS Synchronize/Compare
      CVS Update/Merge
      CVS Watch/Edit
      Editors
      External Tools
      File Associations
      General
      Globalization
      Help
      Help Content
      Install/Update
      Keys
      Label Decorations
      Linked Resources
      Local History
      Network Connections
      Perspectives
      Quick Diff
      Search
      Secure Storage
      Spelling
      SSH2
      Startup and Shutdown
      Team
      Team File Content
      Team Ignored Resources
      Team Models
      Text Editors
      Tracing
      UI Responsiveness Monitoring
      Web Browser
      Workspace
      Workspaces
    Team support with CVS
      CVS
      CVS Checkout wizard
      CVS Console
      CVS History view
      CVS Repositories view
      CVS Workspace Synchronization
      CVS Merge Synchronization
      Merge wizard
      Add CVS Repository wizard
      CVS Sharing wizard
      CVS Label Decorations
      Ignoring resources from version control
    Secure storage
      How secure storage works
      Password recovery
      Life of a master password
      Secure storage runtime options
    User interface information
      Development environment
        Workbench toolbar
        Perspective Bar
        View toolbars
        Builds
        Perspectives
        Local history
        List of key bindings
        Switching workspaces
      Views and editors
        Workbench window layout
        Editor area
        Compare editor
        Search view
        Project Explorer view
        Bookmarks view
        Properties view
        Outline view
        CVS views
        Tasks view
        Problems view
        Ant editor
        Ant view
        Error Log view
      Wizards
        New Project wizard
        New Folder wizard
        New File wizard
        CVS Wizards
        Import wizard
        Export wizard
      Help contents
        Workbench User Guide
        Working with cheat sheets
          Working with composite cheat sheets
      Search
        File search
        Open Resource dialog
      Workbench menus
        File menu
        Edit menu
        Navigate menu
        Project menu
        Window menu
        Help menu
      Icons and buttons
        Project Explorer view icons
        Editor area marker bar
        Tasks view
        Toolbar buttons
        External Tools and Ant Icons
  Tips and tricks
    Workbench
    Editing
    Ant
    Help
    Team - CVS
  What's new
    Editors
    Debug
    Views, Dialogs and Toolbar
    Preferences
    Themes and Styling
    General Updates
  Legal
InterSystems Atelier User Guide
  Getting Started
    Introduction to Atelier
    Atelier User Interface
      Basic UI Concepts
      UI Differences Between Mac and Windows
      Using the Welcome Page
      Navigating the Workbench
      Rearranging the Workbench
  Concepts
    Working with Atelier
    Minimum Required Privileges
    Atelier Server Connection
    Atelier Perspectives
    Atelier Views
    Atelier Projects
    Atelier Classes
    Atelier Editors
    Editor Templates
    Editing Web Applications
    Atelier Search
    Running and Debugging an Atelier Application
    Atelier Import and Export
    Installing and Updating Software
      Updating and Extending Atelier
      Installing the Atelier Plug-in
  Tasks
    Setting up the Workspace
    Improving Start-up Performance
    Configuring a Server Connection
    Creating an Atelier Project
    Creating an Atelier Class File
    Creating an Atelier Routine File
    Creating an Atelier Launch Configuration
    Running an Atelier Application
    Debugging an Atelier Application
    Importing Atelier Source Files
    Exporting Atelier Source Files
    Creating a New Atelier Editor Template
    Installing the Eclipse Web Development Tools
    Editing HTML in CSP Files
    Installing the Eclipse Marketplace Client
    Installing the Eclipse Terminal Plug-in
    Using the Terminal Plug-in
  Reference
    Atelier Preferences
      Caching
      Colors
      Compilation
      Connection
      Debug
      Editors
      Save Settings
      Templates
      Validation
    Atelier Editor
      Atelier Editor Features
      Editor Content Assist
      Atelier Documentation View
    Toolbar Icons for the Atelier Perspective
    Atelier Explorer View
    Project Explorer View
    Server Explorer View
    New Atelier Project
    New Connection Configuration
    Repair Connection
    New Class File
      Select a Class File template
      New Empty Class
      New Business Service Class
      New Business Operation Class
    New Routine File
      Select a Routine File Template
      New Routine File
    New CSP File
    New Custom File: Select Project
    New Custom File: Select Template
    Atelier Search Tab
    Synchronization and Conflict Resolution
    Running and Debugging
      Launch Configurations
      Debug a Running Process
      Toolbar Icons for Debugging
    Import Files from XML
    Export Files to XML
    Configuring an External Webserver
    Troubleshooting
  Studio
    The Studio/Atelier Transition
    Atelier Equivalents for Studio Actions
    Studio Extensions in Atelier
  Samples
    Atelier Code Samples
  Legal
  Release Notes
  Getting Started
    Introduction to Atelier
    Atelier User Interface
      Basic UI Concepts
      UI Differences Between Mac and Windows
      Using the Welcome Page
      Navigating the Workbench
      Rearranging the Workbench
  Concepts
    Working with Atelier
    Minimum Required Privileges
    Atelier Server Connection
    Atelier Perspectives
    Atelier Views
    Atelier Projects
    Atelier Classes
    Atelier Editors
    Editor Templates
    Editing Web Applications
    Atelier Search
    Running and Debugging an Atelier Application
    Atelier Import and Export
    Installing and Updating Software
      Updating and Extending Atelier
      Installing the Atelier Plug-in
  Tasks
    Setting up the Workspace
    Improving Start-up Performance
    Configuring a Server Connection
    Creating an Atelier Project
    Creating an Atelier Class File
    Creating an Atelier Routine File
    Creating an Atelier Launch Configuration
    Running an Atelier Application
    Debugging an Atelier Application
    Importing Atelier Source Files
    Exporting Atelier Source Files
    Creating a New Atelier Editor Template
    Installing the Eclipse Web Development Tools
    Editing HTML in CSP Files
    Installing the Eclipse Marketplace Client
    Installing the Eclipse Terminal Plug-in
    Using the Terminal Plug-in
  Reference
    Atelier Preferences
      Caching
      Colors
      Compilation
      Connection
      Debug
      Editors
      Save Settings
      Templates
      Validation
    Atelier Editor
      Atelier Editor Features
      Editor Content Assist
      Atelier Documentation View
    Toolbar Icons for the Atelier Perspective
    Atelier Explorer View
    Project Explorer View
    Server Explorer View
    New Atelier Project
    New Connection Configuration
    Repair Connection
    New Class File
      Select a Class File template
      New Empty Class
      New Business Service Class
      New Business Operation Class
    New Routine File
      Select a Routine File Template
      New Routine File
    New CSP File
    New Custom File: Select Project
    New Custom File: Select Template
    Atelier Search Tab
    Synchronization and Conflict Resolution
    Running and Debugging
      Launch Configurations
      Debug a Running Process
      Toolbar Icons for Debugging
    Import Files from XML
    Export Files to XML
    Configuring an External Webserver
    Troubleshooting
  Studio
    The Studio/Atelier Transition
    Atelier Equivalents for Studio Actions
    Studio Extensions in Atelier
  Samples
    Atelier Code Samples
  Legal
  Release Notes