Installing the Atelier Plug-in

From the InterSystems Update Site

The best way to get the most up-to-date version of Atelier is from the InterSystems Atelier update site. Go to the Atelier Download page to find links to update sites for the most recent stable version of Atelier and for the current beta version. Select Help > Install New Software from the Eclipse main menu. Copy the site link from the download page and paste it into the Work with field in the install wizard. Select Atelier IDE. Complete the installation following the steps outlined in the Workbench help topic Installing new software.

install from update site

From an Existing Installation

You can install the Atelier plug-in by importing it from an existing installation. Select File > Import > Install > From Existing Installation from the main menu and click Next. The From application installation field in the Import wizard must point to the directory where Atelier is installed. On Windows, this is the install directory. On Mac OSX, it is the Eclipse directory in the Atelier.app application bundle. Select only the item labeled Atelier IDE. This contains the plug-in content that you want to install.

select the application folder

From an Exported File

You can also install the Atelier plug-in from a file that contains the plug-in exported from another installation. To export the plug-in, select File > Export > Install > Installed Software Items to File from the main menu. Export only the item labeled Atelier IDE. The operation creates a file with an extension .p2f.

To import the plug-in, select File > Import > Install > Install Software Items from File. The field From description file must point to a .p2f file exported from Eclipse.

Related concepts

Updating and Extending Atelier