Atelier Explorer View

Open by selecting Window > Show View > Atelier Explorer from the main menu, or by clicking this link: Opens the new Class file wizard Atelier Explorer.

The Atelier Explorer view shows the logical structure of projects in the workspace. It lists projects you create, and shows the contents of each Atelier project organized in logical groupings: Classes, Routines, and CSP files. Class files are grouped by package. Files containing routines are grouped by package if they have been assigned a package. Click the disclosure triangle to the left of the file name to see objects defined in the file. Double-clicking on an object listing takes you to the declaration of that object in an editor, opening the file if necessary.

Each project also has a node for the Namespace Library. It lists resources available through the project's server connection, and is labeled with the names of the connection and namespace..

Toolbar Commands

The following commands are available from buttons in the Atelier Explorer view toolbar:

Toolbar Button Command Description
Navigate backward Go Back Navigate backwards.
Navigate forward Go Forward Navigate forward.
Navigate up Up Navigate up one level in the hierarchy.
Collapse all Collapse All Collapses all expanded nodes in the view.
Link with editor Link with Editor Enables you to navigate to a file open in an editor by selecting it in the Atelier Explorer. Acts as a toggle. When the button is selected, linkage with the editor is in effect, and when it is not selected there is no linkage.
Synchronize project Synchronize Project Synchronizes in selected project(s) with files in the associated namespace for selected project(s).
View menu View Menu Displays the Atelier Explorer menu.

View Menu Commands

Commands on the Atelier Explorer view menu include the following:

Command Description
Select Working Set Opens a dialog you can use to select one or more working sets to display in the view. The dialog also lets you edit or remove existing working sets. For more information, see the discussion of working sets in Basic UI Concepts.
Deselect Working Set Removes the working set selection.
Edit Active Working Set Opens a dialog you can use to edit the contents of the currently active working set.
Filters Lets you fine tune the display you see in the Atelier Explorer by applying filters that exclude certain types of resources. See the section View Filters for a discussion of the available filters.
Link With Editor Enables you to navigate to a file open in an editor by selecting it in the Atelier Explorer. Duplicates the action of the Link With Editor toolbar command.

View Filters

Filters available through the Filters command on the View menu include:

Filter Description
.* resources Hide all files starting with "."
Closed projects Hide all closed projects. Projects can be opened and closed from the Project menu or the context menu.
Fields Hide methods, properties, attributes and other class members.
Folders without source Hide folders that do not contain source files.
Import declarations Hide Import declarations.
Non-Atelier elements Hide projects not created as Atelier projects.
Non-Atelier projects Hide all non-Atelier projects.
Non-shared projects Hide all projects that are not shared with a version control system.
Package declarations Hide package declarations.

Content Icons

The following icons indicate types of workspace content shown in the Atelier Explorer:

Icon Description
Atelier Project Atelier Project
Closed Atelier Project Closed Atelier Project
Logical Grouping Logical Grouping, such as Classes or Routines
Package Package
Class File Class File
Property or Parameter Property or Parameter
Method Method
MAC File MAC File
INC File INC File
INT File INT File
Namespace Library Namespace Library

Icon Decorators

Additional graphic symbols can appear on the icons for items displayed in the Atelier Explorer. These include:

Decorator Description
Warning decorator Warning. Often indicates that the resource is out of synchronization with the server.
Error decorator Error. Often indicates a syntax error.
Static decorator Static. Indicates that the class member is static.

Context Menu Commands

Commands available from the Atelier Explorer context menu vary depending on which nodes in the tree you have selected. These commands include:

Command Description
New Select a wizard to create a new resource. The submenu lists Atelier-specific selections.
Go Into Navigate down the hierarchy to show only the selected project. Available on a project node.
Open in New Window Opens a new Atelier window showing only the selected project. Available on project nodes.
Open Opens the selected resources using the default editor. Available on file nodes.
Open With Opens the selected resource using the selected editor. Available on file nodes.
Import Opens the Import dialog, where you can select the type of import you want to perform.
Export Opens the Export dialog, where you can select the type of export you want to perform.
Refresh Refreshes the view content.
Close/Open Project Close project closes the selected project. Visible when an open project is selected. Open project opens the selected project. Visible when a closed project is selected.
Close/Open Unrelated Projects Close or open projects unrelated to the selected project.
Run As Opens a submenu of run options. When an appropriate Atelier source file is selected, you can run it as an Atelier Application, or open the Run Configurations wizard.
Debug As Opens a submenu of debug options. When an appropriate Atelier source file is selected, you can debug it as an Atelier Application, or open the Debug Configurations wizard.
Team Opens a submenu. If the project is associated with a source code control (SCC) system, the submenu lists SCC options. If not, you can use the submenu item Share Project... to associate the project with SCC.
Compare With When you have selected a file node, the submenu item Server's Copy compares the selected file with the version on the server. See the detailed description following this table.
Synchronize Synchronizes the selected resources on the client with the versions on the server.
Compile Compiles selected files.
Compile Project Compiles all files in one or more projects.
Edit Connection Opens the Connection Configuration wizard on the connection associated with the selected project. You can edit the web server configuration or the user credentials. You cannot edit the connection name, which would change the connection. Available on project nodes.
Change Connection Lets you change the server connection associated with a project. This is especially useful if a connection is unavailable. See the section on Repairing Orphaned Projects in the topic: Server Explorer View.

Comparing Client and Server Files

The context menu selection Compare With > Server's Copy compares the version of the selected file saved in your workspace with the version on the server. You can use this command before saving a file, to check whether it has changed on the server. If you set the Atelier Save Settings preference to Save, you can edit and save files on the client, then compare the client and server versions to review your changes before synchronizing to the server.

Related concepts

Atelier Views
Atelier Perspectives

Related tasks

Configuring a Server Connection
Creating an Atelier Project
Creating an Atelier Class File
Creating an Atelier Routine File

Related reference

Save Settings
Synchronization and Conflict Resolution
New Connection Configuration
Repair Connection
Server Explorer View
Project Explorer View