Server Explorer View

Open by selecting Window > Show View > Server Explorer from the main menu, or by clicking this link: Opens the new Class file wizard Server Explorer.

The Server Explorer view lists all server configurations you have created. When you select a connection in the Server Explorer, the Properties view shows the host name, connection name, port, status, and username associated with that connection:

Connection properties

Click the tree control to the left of the connection name to open the node and show the namespaces defined on the server. Every connection has at least the four standard namespaces: %SYS, DOCBOOK, SAMPLES, and USER. Within each namespace, resources are grouped into Classes, Routines, and CSP files. The following image shows the standard namespaces, and the file groupings in the USER namespace.

Namespaces in server explorer

You can continue to expand the tree to see folders, packages and files in each category. Clicking on a file opens it in an editor in read-only mode. The editor displays the file with a background color that distinguish it from a local file in a project. You can configure the colors used in the Atelier color preferences. See Colors. The default colors are white for local writable files and gray for read-only files on the server. The following image shows a class file on the server open in an editor.

Server file open in the editor

Note: The Server Explorer does not reference projects. The project is a concept relevant to development in Atelier that has no meaning in the context of code compilation and storage on the server. If you create two projects, both attached to the same server connection and namespace, and both projects have a resource with the same package and class or routine name, both files point to the same resource on the server, even though they reside in different projects and are stored in different files and directories on the client.

Server Explorer Toolbar

The following commands are available from buttons in the Server Explorer view toolbar:

Toolbar Button Command Description
collapse all Collapse All Collapses all expanded nodes in the view.
link with editor Link with Editor Enables you to navigate to a file open in an editor by selecting it in the Server Explorer. Acts as a toggle. When the button is selected, linkage with the editor is in effect, and when it is not selected there is no linkage.
Add connection Add Connection Opens the Connection Configuration wizard which lets you add a new connection.
Delete connection Delete Deletes the selected resource.
Delete connection Refresh Refreshes the view content.
View menu View Menu Displays the Server Explorer menu. This menu gives you access to the Filters and Customization dialog.

Filters and Customization

Tab Command Description
Filters Generated files When this check box is selected, intermediate files generated during compilation are hidden from view. If you want to see generated files, clear this check box. The compilation preference Keep generated source code (k) must be selected in order to retain the generated files. It is selected by default. See Compilation.
System files When this check box is selected, system files are hidden. If you want to see system files, clear this check box.
Content Connections Controls display of connection nodes. If you clear this check box, the view is completely empty of content.
CSP applications Controls display of CSP applications. If you clear this check box, the CSP files node and everything under it are removed from the view.

Content Icons

The following icons indicate types of content shown in the Server Explorer:

Icon Description
Connection Connection
Namespace Namespace
Logical grouping Class or routine grouping
Package Package
Class File Class File
MAC File MAC File
INC File INC File
INT File INT File
CSP Folder CSP Folder
CSP Folder CSP Sub-folder
CSP File CSP File

You can select one or more files or one or more entire packages and right-click to open a context menu that lets you copy the selected resources from the server to a project in your workspace. In the situation depicted in the next image, selecting Copy to Project copies the content of the Aviation package from the USER namespace on the server to a project in your workspace.

Copy to project command in Server Explorer

Server Explorer Context Menu

The following commands are available from the Server Explorer context menu:

Icon Command Description
Edit connection Edit Connection Runs the Connection Configuration wizard on the selected connection. In this mode, the Connection Name field is read-only. Available on connection nodes.
Add connection Add Server Connection Runs the New Connection Configuration wizard. Available on connection nodes.
Delete server connection Delete Server Connection Deletes the selected connection. If you attempt to delete a connection that has one or more projects associated with it, you get a warning that lists the projects and allows you to cancel the operation. If you override this warning and delete the connection, the projects are left 'orphaned' and non-functional. See the discussion of repairing orphaned projects that follows this table. Available on connection nodes.
Drop cache Drop cache Available on connection nodes.
Refresh Refresh Refresh the view contents. Available on connection and namespace nodes.
Management Portal Management Portal Opens the Management Portal for this connection in a browser. Available on connection nodes.
Copy to Project Copy to Project Copies the selected resources to a project in your workspace. Available on all nodes below namespace.
Delete Delete Deletes the selected resources from the server. Available on all nodes below namespace.
  Run As Hover to select Run Configurations.... Available on file-level nodes.
  Debug As Hover to select Debug Configurations.... Available on file-level nodes.
  Profile As Hover to select Profile Configurations.... Available on file-level nodes.
Add connection View Server Resource Opens the file for read-only access in an Atelier editor. The editor background is grey to indicate that the file is on the server and cannot be edited. Available on file-level nodes.
  Open With Hover to reveal a list of available editors.

Repairing Orphaned Projects

To repair projects that are orphaned because of a deleted server connection, right-click on the project in either the Atelier Explorer or the Project Explorer and select Change Connection from the context menu. This command opens the Repair Connection wizard. By default, the project that invoked the wizard is selected. You can select additional projects that you want to repair. Select a connection you have already configured, or create a new connection, then select a namespace. Click OK to repair all selected projects by assigning them the connection and namespace. If you select a project that already has a valid server connection, the wizard changes the connection to the values you have provided.

Related concepts

Atelier Views
Atelier Perspectives
Atelier Server Connection

Related tasks

Configuring a Server Connection

Related reference

New Connection Configuration
Atelier Explorer View
Project Explorer View