Setting up the Workspace

Line Endings

Atelier files can use Unix- or Windows-style line endings. When you copy source code from a server to a project in Atelier, the copy process must add line endings because there are no line endings in the code as stored on the server. Atelier uses the line-ending style specified for the project. You can set line ending style in the following ways.

For currently selected files:

  1. Select File > Convert Line Delimiters To on the main menu.
  2. From the submenu, select the desired line ending style.

This action alters the line delimiters in files that are currently selected. Changes are immediate and persist until you change the delimiter again. You do not need to save the file.

For a project:

To set the line ending style for a project in your workspace:

  1. Select Project > Properties > Resource from the main menu.
  2. Use the controls toward the bottom of the project properties page to specify the line ending used for new files in the project.
  3. If you do not specify a line ending style for the project, it uses the style from the workspace.

For the entire workspace:

  1. Select Window > Preferences from the main menu.
  2. On the General workspace preferences General > Workspace page, use the controls in the lower-right corner, as shown, to specify the line ending used for all new files in the workspace:

    Compile

Line endings and source control:

While there are no line ending requirements within the Atelier client, if you are using a source code control system, that tool may require specific line ending settings. You need to ensure that both Atelier and your source control system use the same line endings.

Text File Encoding

Text file encoding support allows you to tell Atelier what the correct encoding is for your text file resources. Generally, you set the encoding for your workspace or project prior to creating or importing files. You should select an encoding appropriate for the resources and languages you will be using. You can select a different encoding on a per-file basis if necessary.

For a file active in the editor:

  1. Select Edit > Set Encoding on the main menu.
  2. Use the dialog box to select a text encoding:

    Compile

For a file selected in the Atelier Explorer:

  1. Select File > Properties.
  2. The dialog box lets you set a number of file properties. Controls to select text encoding are located at the bottom of the window.

This action alters the text encoding assigned to the file. The changes is immediate and persists until you change the delimiter again. You do not need to save the file.

For a project:

To set the text file encoding for a project in your workspace:

  1. Select Project > Properties > Resource from the main menu.
  2. Controls to select set text encoding are located next to those for line ending style.
  3. If you do not specify a text encoding for the project, it uses the encoding from the workspace.

For the entire workspace:

  1. Select Window > Preferences from the main menu.
  2. On the General workspace preferences General > Workspace page, controls to select set text encoding are located next to those for line ending style.