Caché スタジオの使用法
目次
 
   
サーバ:docs1
インスタンス:LATESTJ
ユーザ:UnknownUser
 
-
移動:
検索:    

 
目次

序文: 
 
 
チャプター1: 
 
  • 1.1 スタジオ・ウィンドウの概要
  • 1.1.1 コマンド行からのスタジオの実行
  • 1.2 プロジェクト
  • 1.3 クラス定義
  • 1.3.1 テキストとしてのクラス定義
  • 1.4 CSP ファイル
  • 1.5 ルーチン・エディタ
  • 1.6 複数のユーザへのサポート
  • 1.7 Caché ドキュメントのローカルでのインポートおよびエクスポート
  • 1.8 デバッグ
  • 1.8.1 オブジェクト・ベースのアプリケーションのデバッグ
  • 1.9 Caché セキュリティとの統合
  • 1.10 ソース・コントロール・フック
  • チャプター2: 
     
  • 2.1 プロジェクトの作成
  • 2.2 データベースの作成
  • 2.2.1 新規クラスの定義
  • 2.2.2 プロパティの追加
  • 2.2.3 クラスの保存とコンパイル
  • 2.2.4 クラス・ドキュメントの表示
  • 2.3 CSP を使用した Web ユーザ・インタフェースの作成
  • 2.3.1 CSP ファイルの作成
  • 2.3.2 CSP ファイルの保存とコンパイル
  • 2.3.3 Web ページの表示
  • 2.4 Zen を使用した Web ユーザ・インタフェースの作成
  • 2.4.1 クラスをデータ・アダプタに設定
  • 2.4.2 Zen ページの作成
  • 2.4.3 Zen フォームの追加
  • 2.4.4 クライアント側メソッドの追加
  • 2.4.5 テーブルでのデータベースの表示
  • チャプター3: 
     
  • 3.1 新規のクラス定義の作成
  • 3.1.1 新規クラス・ウィザード
  • 3.1.2 新規クラス・ウィザード実行の結果
  • 3.2 クラス定義をオープンする
  • 3.3 クラス定義の編集
  • 3.4 クラス定義の保存および削除
  • 3.5 クラス定義のコンパイル
  • 3.5.1 増分コンパイル
  • 3.6 クラス定義の名前を変更する
  • 3.7 クラス・インスペクタ
  • 3.7.1 クラス・インスペクタの起動
  • 3.8 クラス・ブラウザ
  • 3.9 スーパークラス・ブラウザと派生クラス・ブラウザ
  • 3.9.1 スーパークラス・ブラウザ
  • 3.9.2 派生クラス・ブラウザ
  • 3.10 パッケージ情報
  • チャプター4: 
     
  • 4.1 新規プロパティ・ウィザード
  • 4.1.1 名前および説明ページ
  • 4.1.2 プロパティ・タイプ・ページ
  • 4.1.3 プロパティの特性ページ
  • 4.1.4 データ型パラメータ・ページ
  • 4.1.5 プロパティ・アクセサ・ページ
  • 4.1.6 新規プロパティ・ウィザード実行の結果
  • チャプター5: 
     
  • 5.1 新規メソッド・ウィザード
  • 5.1.1 名前および説明ページ
  • 5.1.2 メソッド・シグニチャ・ページ
  • 5.1.3 メソッド特性ページ
  • 5.1.4 実装ページ
  • 5.1.5 新規メソッド・ウィザード実行の結果
  • 5.2 メソッドのオーバーライド
  • チャプター6: 
     
  • 6.1 新規クラス・パラメータ・ウィザード
  • チャプター7: 
     
  • 7.1 リレーションシップ・プロパティを作成する新規プロパティ・ウィザード
  • 7.1.1 名前および説明ページ
  • 7.1.2 プロパティ・タイプ・ページ
  • 7.1.3 リレーションシップの特性ページ
  • 7.1.4 その他の変更
  • 7.1.5 新規プロパティ・ウィザードで新規のリレーションシップを作成した結果
  • チャプター8: 
     
  • 8.1 新規クエリ・ウィザード
  • 8.1.1 名前、実装、および説明ページ
  • 8.1.2 入力パラメータ・ページ
  • 8.1.3 列ページ
  • 8.1.4 条件ページ
  • 8.1.5 照合順ページ
  • 8.1.6 行指定形式ページ
  • 8.1.7 新規クエリ・ウィザード実行の結果
  • チャプター9: 
     
  • 9.1 新規インデックス・ウィザード
  • 9.1.1 名前および説明ページ
  • 9.1.2 インデックス・タイプ・ページ
  • 9.1.3 インデックス・プロパティ・ページ
  • 9.1.4 インデックス・データ・ページ
  • 9.1.5 新規インデックス・ウィザード実行の結果
  • 9.2 インデックスの配置
  • チャプター10: 
     
  • 10.1 新規プロジェクション・ウィザード
  • 10.1.1 名前および説明ページ
  • 10.1.2 プロジェクション・タイプ・ページ
  • 10.1.3 新規プロジェクション・ウィザード実行の結果
  • チャプター11: 
     
  • 11.1 新規 XData ウィザード
  • チャプター12: 
     
  • 12.1 SQL エイリアス
  • 12.2 SQL ストアド・プロシージャ
  • 12.2.1 クエリ・ベースのストアド・プロシージャ
  • 12.2.2 メソッド・ベースのストアド・プロシージャの作成
  • 12.3 クラスへの SQL トリガの追加
  • 12.3.1 新規 SQL トリガ・ウィザード
  • 12.4 クラスへの新規 SQL 外部キーの追加
  • 12.4.1 新規 SQL 外部キー・ウィザード
  • チャプター13: 
     
  • 13.1 クラスへのストレージ定義の追加
  • 13.1.1 新規ストレージ・ウィザードを使用する方法
  • 13.2 クラス・インスペクタをストレージ定義で使用する
  • 13.3 クラス・エディタをストレージ定義で使用する
  • チャプター14: 
     
  • 14.1 CSP サンプル・ページ
  • 14.2 新規の CSP ファイルの作成
  • 14.2.1 Default.csp テンプレート・ファイル
  • 14.3 CSP ファイルの編集
  • 14.3.1 挿入オプション
  • 14.4 CSP ファイルの保存
  • 14.5 CSP ファイルのコンパイル
  • 14.6 CSP ファイルの結果の表示
  • 14.7 任意の URL に対する構文カラー表示のソースの表示
  • チャプター15: 
     
  • 15.1 ルーチン・エディタ
  • 15.2 ルーチン・ソース形式
  • 15.3 新規のルーチンまたはインクルード・ファイルの作成
  • 15.4 既存のルーチンまたはインクルード・ファイルを開く
  • 15.5 ルーチン・テンプレート・ファイル
  • 15.6 ルーチンの保存、コンパイル、および削除
  • 15.7 ルーチン、インクルード、および CSP ファイルのバックアップの自動保存
  • チャプター16: 
     
  • 16.1 デバッグ・セッションのサンプル : ルーチンのデバッグ
  • 16.2 現在のプロジェクトのデバッガ設定
  • 16.2.1 デバッグ対象
  • 16.2.2 ブレークポイント
  • 16.3 [デバッグ] メニュー
  • 16.4 ウォッチ・ウィンドウ
  • 16.4.1 デバッガ・ウォッチ・ウィンドウ・コンテキスト・メニュー
  • チャプター17: 
     
  • 17.1 スタジオ・テンプレートへのアクセス
  • 17.2 Caché 付属の標準スタジオ・テンプレート
  • 17.2.1 テンプレート
  • 17.2.2 クラス定義テンプレート
  • 17.2.3 Zen テンプレート
  • 17.2.4 アドイン・テンプレート
  • 17.3 独自のスタジオ・テンプレートの作成
  • 17.3.1 テンプレート・アーキテクチャ
  • 17.3.2 デフォルト・テンプレート・タイムアウト
  • 17.3.3 シンプル・テキスト・テンプレート
  • 17.3.4 インタラクティブ・スタジオ・テンプレート
  • 17.3.5 新規ドキュメント・スタジオ・テンプレート
  • 17.3.6 ドキュメントの末尾へのテキストの追加
  • 17.3.7 アドイン・スタジオ・テンプレート
  • チャプター18: 
     
  • 18.1 [ファイル] メニュー
  • 18.2 [編集] メニュー
  • 18.2.1 基本的な編集
  • 18.2.2 検索と置換
  • 18.2.3 ブックマーク
  • 18.2.4 その他の編集
  • 18.3 [ビュー] メニュー
  • 18.3.1 ツールバー
  • 18.3.2 カスタマイズ・ツールバー
  • 18.4 [プロジェクト] メニュー
  • 18.4.1 一般的なプロジェクト・タスク
  • 18.5 [クラス] メニュー
  • 18.6 [ビルド] メニュー
  • 18.7 [デバッグ] メニュー
  • 18.8 [ツール] メニュー
  • 18.9 [ユーティリティ] メニュー
  • 18.10 [ウィンドウ] メニュー
  • 18.11 [ヘルプ] メニュー
  • 18.12 コンテキスト・メニュー
  • 18.12.1 エディタ・コンテキスト・メニュー
  • 18.12.2 ワークスペース・コンテキスト・メニュー
  • 18.12.3 インスペクタ・コンテキスト・メニュー
  • 18.12.4 タブ・コンテキスト・メニュー
  • 18.12.5 ウィンドウ表示のコンテキスト・メニュー
  • 18.12.6 デバッガ・ウォッチ・コンテキスト・メニュー
  • 18.13 キーボード・アクセラレータ
  • 18.13.1 MultiValue 文字の挿入
  • 18.14 スタジオ・メニューの追加
  • チャプター19: 
     
  • 19.1 環境オプション
  • 19.2 エディタ・オプション
  • 19.3 コンパイル・オプション
  • 19.4 SQL オプション
  • 19.5 スタジオの外観のオプション
  •  
    付録A: 
     
  • A.1 概要
  • A.2 Caché ドキュメント
  • A.2.1 ドキュメントとファイルを管理するツール
  • A.2.2 内部名と外部名をマップする方法の指定
  • A.3 ソース・コントロール・クラスの作成と有効化
  • A.3.1 スタジオの拡張
  • A.3.2 ソース・コントロール・クラスの作成
  • A.3.3 ソース・コントロール・クラスの有効化
  • A.4 ソース・コントロール・システムへのアクセス
  • A.4.1 例 1
  • A.4.2 例 2
  • A.5 サンプルのソース・コントロール・クラス
  • A.5.1 はじめに
  • A.5.2 グローバル
  • A.5.3 外部名の指定
  • A.5.4 Caché ドキュメントと外部ファイルの同期化
  • A.5.5 Caché ドキュメントの状態の制御
  • A.5.6 ソース・コントロール・アクション
  • A.5.7 その他の詳細
  • 付録B: 
     
  • B.1 クラス定義の例
  • B.2 一般的な構造
  • B.2.1 生成とフォーマット
  • B.2.2 文
  • B.2.3 コメント
  • B.2.4 インターシステムズ・クラス・リファレンスで使用されるコメント
  • B.3 文
  • B.3.1 Class 文
  • B.3.2 Parameter 文
  • B.3.3 Property 文
  • B.3.4 Relationship 文
  • B.3.5 Index 文
  • B.3.6 Method 文と ClassMethod 文
  • B.3.7 SQL Query 文
  • B.3.8 Projection 文
  • B.3.9 SQL Trigger 文
  • B.3.10 SQL ForeignKey 文
  • 付録C: