Basic UI Concepts

This section provides a brief overview of key concepts that are basic to understanding the Atelier UI. For further information, see the Workbench User Guide.

Workspace

The folder on your local disk that contains projects and other information about your work in Atelier. You must select a workspace when you launch Atelier. The following image shows the dialog used to select a workspace:

Workspace launcher

You can change to a different workspace by selecting File > Switch Workspace from the main menu. Atelier closes and reopens using the new workspace.

Working Set

A working set groups workspace resources for display in views, or to have operations performed on them.

The following image shows the Atelier Explorer with four projects and the menu opened by clicking on the down-arrow in the view toolbar:

Atelier Explorer view menu

Select Select working set to open a dialog that lets you create and select working sets. This image shows two working sets that have already been defined, Even Projects and Odd Projects. Click on the New button to create a new working set.

Select Working Set

In the dialog that appears, select Script Working Set then Next.

Select working set type

Use the dialog that opens to enter a name for the working set, in this case Prime Projects, and select the projects to be included in the new working set and click Finish.

New working set

The list of working sets now includes the new one. Select it and click OK.

Working set added

The Atelier Explorer now shows only the members of the Prime Projects working set.

Atelier Explorer showing members of working set

Workbench

A general term for the Atelier desktop development environment.

Perspective

A set of views presented in the Workbench. The views are selected to help you perform a group of related tasks. Frequently used perspectives include the Atelier perspective, which is intended for editing source files:

Atelier perspective

And the debug perspective, used in debugging:

Debug perspective

You can open perspectives from the Window > Perspective command on the main menu bar, or from the Perspective bar in the upper right corner of the workbench.

View

A visual display that helps you view and navigate information. You can open views from the Window > Show View command on the main menu bar. The following image shows the Atelier Explorer view:

Atelier Explorer view
Editor area

The visual display area in which you edit files. You can open numerous files using many different editors in the editor area. The following image shows a class file open in the Atelier CLS editor:

Editor area
View stack

A group views or files opened by an editor which are displayed as tabs in single viewing area in the Atelier window. A view stack can be maximized to occupy the entire window, or minimized to icons in the window trim. The following image shows the Atelier Explorer, Server Explorer, and Project Explorer open in a view stack:

View stack

The next image shows the same view stack minimized in the window trim:

View stack minimized in window trim

Related Eclipse documentation

Workbench User Guide