Atelier Keyboard Shortcuts

Eclipse provides a number of keyboard shortcuts that can speed your work with the Atelier plugin. The following table summarizes some of the most useful. The table lists both Mac and Windows variations. For the most part, they follow the standard convention that shortcuts initiated with CTRL on Windows are initiated with CMD on Mac, but there are exceptions, so look carefully.

You can both examine and customize keyboard shortcuts by selecting Window > Preferences from the main menu and then selecting General workspace preferences General > Keys. The Eclipse help topic Keys provides further information on keyboard shortcuts.

Command Menu Item Atelier Keyboard Shortcut See also ...
Windows Mac
Code completion/Content assist   CTRL+SPACE CTRL+SPACE Editor Content Assist
Navigate to a specific line number. Navigate > Go to Line; enter line number CTRL+L CMD+L Go To Line...
Navigate to a routine label or class member Navigate > Go to Line; enter label or member name, plus offset CTRL+L CMD+L Go To Line...
Open declaration Editor Context Menu > Open Declaration F3 F3 Open Declaration
View code generated by the compiler, such as .int and .mac files Editor Context Menu > View Others CTRL+SHIFT+V CMD+SHIFT+V View Other Code
Use the IDE in full screen mode Window > Appearance > Toggle Full Screen ALT+F11 CTRL+CMD+F Rearranging the Atelier Workbench
Quick outline CTRL+O CMD+O Quick Outline
View other code CTRL+SHIFT+V CMD+SHIFT+V View Other Code
Open Atelier class/routine Navigate > Open Atelier Class/Routine CTRL+SHIFT+T CMD+SHIFT+T Open Atelier Class/Routine
Open resource CTRL+SHIFT+R CMD+SHIFT+R Open Resource
Go back Navigate > Back CTRL+left arrow CMD+[ Navigation Forward and Back
Go forward Navigate > Forward CTRL+right arrow CMD+] Navigation Forward and Back
Return to last edit location Navigate > Last Edit Location CTRL+Q CTRL+Q Navigation Forward and Back
Save File > Save CTRL+S CMD+S  
Synchronize CTRL+ALT+S CMD+OPTION+S Complation and Synchronization
Compile ALT+C OPTION+C Complation and Synchronization
Toggle word wrapping for a given file ALT+SHIFT+Y CMD+OPTION+Y
Launch Search utility Search > Search... CTRL+H CTRL+H Atelier Search Tab
Toggle breakpoint Run > Toggle Breakpoint (Debug Perspective) CTRL+SHIFT+B CMD+SHIFT+B Debug Perspective