Installing the Eclipse Terminal Plug-in

Atelier does not provide a terminal, but a terminal plug-in is available that enables you to connect to the server. This plug-in may have been installed as part of your Eclipse installation. If it is not, you can obtain it from the Eclipse repository:

  1. Navigate to command link Help > Install New Software from the main menu.
  2. Select the Eclipse repository () from the drop-down list in the Work with field. If that repository is not available, click the Manage... button to add or enable it in the Available Software Sites preferences. Ensure that the Group items by category check box is selected.
  3. Once Eclipse has populated the list of available software, you can type TM or terminal in the filter text field. Select the item TM Terminal.
  4. Click Next to open the Install Details page. Review your installation choices.
  5. Click Next to open the Review Licenses page. Accept the license terms and click Finish.
  6. To open the Terminal view, select Window > Show View > Other on the main menu. In the the Show View dialog, open the Terminal node, select Terminal and Open.

Related InterSystems documentation

Terminal

Related concepts

Updating and Extending Atelier

Related tasks

Using the Terminal Plug-in