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About This Book
This book explains how to access InterSystems databases from .NET client applications. It contains the following sections:
•

Introduction provides information on installation, project configuration, binding architecture, and sample programs.

•

Connecting to the InterSystems Database provides detailed information about database connections (including connection
pooling).

•

Using ADO.NET Managed Provider Classes gives concrete examples using the InterSystems implementation of the
ADO.NET Managed Provider API.

•

Using the Entity Framework Provider describes how to setup and get started using the InterSystems implementation
of Entity Framework Provider.

There is also a detailed Table of Contents.
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1
Introduction
This book describes how to use the SqlClient .NET assembly, which provides two different but complementary ways to
access InterSystems databases from a .NET application:
•

The ADO.NET Managed Provider — is InterSystems implementation of the ADO.NET data access interface. It provides
easy relational access to data using the standard ADO.NET Managed Provider classes (see “Using ADO.NET Managed
Provider Classes”).

•

The Entity Framework Provider — is the InterSystems implementation of the object-relational mapping (ORM)
framework for ADO.NET. It enables .NET developers to work with relational data using domain-specific objects (see
“ Using the Entity Framework Provider” ).

The SqlClient assembly is implemented using .NET managed code throughout, making it easy to deploy within a .NET
environment. It is thread-safe and can be used within multithreaded .NET applications. This chapter describes how to install
the Managed Provider (see “SqlClient Installation and Configuration ”) and provides additional instructions for setting up
Entity Framework (see “Setting Up the Entity Framework Provider ”).
Note:

The .NET Help File
The .NET help file provides the most current and detailed documentation for both object and relational APIs. This
file is named IrisProvider.chm, and it is available as a stand-alone help file in <iris-install-dir>\dev\dotnet\help.

1.1 SqlClient Installation and Configuration
This section provides specifies requirements, and provides instructions for installing the SqlClient assembly and configuring
Visual Studio.

1.1.1 Requirements
•

The .NET Framework, versions 2.0, 4.0, or 4.5.

•

InterSystems IRIS.

•

Visual Studio 2013 or later.

InterSystems IRIS is not required on computers that run your .NET client applications, but the clients must have a TCP/IP
connection to the InterSystems server and must be running a supported version of the .NET Framework.

Using the InterSystems Managed Provider for .NET
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1.1.2 Installation
The SqlClient assembly (InterSystems.Data.IRISClient.dll) is installed along with the rest of InterSystems IRIS, and requires
no special preparation.
•

When installing InterSystems IRIS in Windows, select the Setup Type: Development option.

•

If InterSystems IRIS has been installed with security level 2, open the Management Portal and go to System Administration
> Security > Services, select %Service_CallIn, and make sure the Service Enabled box is checked. If you
installed InterSystems IRIS with security level 1 (minimal) it should already be checked.

To use the SqlClient assembly in a .NET project, you must add a reference to the assembly, and add the corresponding
Using statements to your code (as described in the following section).
There is a separate version of InterSystems.Data.IRISClient.dll for each supported version of .NET. These files are located
in the following subdirectories of <iris-install-dir>\dev\dotnet\bin:
•

.NET version 2.0: \bin\v2.0.50727

•

.NET version 4.0: \bin\v4.0.30319

•

.NET version 4.5: \bin\v4.5

See “ InterSystems IRIS Installation Directory ” in the Installation Guide for the location of <iris-install-dir> on your system.
All InterSystems assemblies for .NET are installed to the .NET GAC (Global Assembly Cache) when InterSystems IRIS
is installed.

1.1.3 Configuring Visual Studio
This section describes how to set up a Visual Studio project using the SqlClient assembly.
To add a SqlClient assembly reference to a project:
1.

From the Visual Studio main menu, select Project > Add Reference

2.

In the Add Reference window, click on Browse...

3.

Browse to the subdirectory of <iris-install-dir>\dev\dotnet\bin that contains the assembly for the version of .NET used
in your project (as listed in the previous section), select InterSystems.Data.IRISClient.dll, and click OK.

4.

In the Visual Studio Solution Explorer, the InterSystems.Data.IRISClient assembly should now be listed under References.

Add Using Statements to the Application
Add Using statements for the two main namespaces in the InterSystems.Data.IRISClient.dll assembly before the beginning
of your application's namespace. InterSystems.Data.IRISClient provides code in the namespace InterSystems.Data.IRISClient,
so this namespace must be referenced in the using statement.
using InterSystems.Data.IRISClient;
namespace DotNetSample {
...
}

Both the SqlClient and IRISTypes namespaces are included in the InterSystems.Data.IRISClient.dll assembly.
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1.2 Setting Up the Entity Framework Provider
Follow the instructions in this section if you want to use the InterSystems Entity Framework Provider.

1.2.1 System Requirements
To use Entity Framework Provider, you need the following software:
•

Visual Studio 2013 (Professional or Ultimate) with Update 5 (or later update)

•

InterSystems IRIS Entity Framework Provider distribution, located in the directory install-dir\dev\dotnet\bin\v4.0.30309.
This directory includes the following files, which you use in the setup instructions:
–

IrisEF.zip, installation files.

–

IrisEF.zip\setup.cmd, which installs the DLLs InterSystems.Data.IRISClient.dll and InterSystems.Data.IRISVSTools.dll.

–

IrisEF.zip\Nuget\InterSystems.Data.Entity6.4.5.0.0.nupkg which installs Entity Framework Provider.

–

IrisEF.zip\CreateNorthwindEFDB.sql which is used to create a sample database.

1.2.2 Run Setup and Set Variables
Follow these steps:
1.

Extract the contents of install-dir\dev\dotnet\bin\v4.0.30309\IrisEF.zip into a folder (in the same directory as the zip file)
called IrisEF. Run \IrisEF\setup.cmd.

2.

In Windows, select All Programs > Visual Studio 2013 > Visual Studio Tools.

3.

In the displayed Windows Explorer folder, right-click Developer Command Prompt for VS2013 > Run as Administrator
and enter:
devenv /setup

This command repopulates this key from HKEY_LOCAL_MACHINE:
HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0_Config //VS 2013

1.2.3 Copy Files to Visual Studio
Copy the two files from the IrisEF directory to Visual Studio:
•

SSDLToIrisSQL.tt

•

GenerateIrisSQL.Utility.ttinclude

from the directory <iris-install-dir>\dev\dotnet\bin\v4.0.30319\IrisEF\Templates to the directory C:\Program Files
(x86)\Microsoft Visual Studio 1x.0\Common7\IDE\Extensions\Microsoft\Entity Framework Tools\DBGen

1.2.4 Connect Visual Studio to the Server
To connect Visual Studio to an InterSystems database instance, follow the steps below:
1.

Open Visual Studio and select View > Server Explorer.
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2.

Right-click Data Connections and select Add Connection. In the Add Connection Dialog:
a.

Select Data source as InterSystems IRIS Data Source (.Net Framework Data Provider for
InterSystems IRIS)

b.

Select Server

c.

Enter Username and password. Click Connect.

d.

Select a namespace from the list. Click OK.

1.2.5 Configure Nuget Local Repository
Follow these steps to configure the Package Manager to find the local Nuget repository:
1.

Create a directory as a Nuget repository. You might call it Nuget Repository. You could put it anywhere – a good
choice might be <yourdoclibraryVS2013>\Projects (where Visual Studio stores projects by default).

2.

Copy the file <installdir>\dev\dotnet\bin\v4.0.30319\IrisEF\Nuget\InterSystems.Data.Entity6.4.5.0.0.nupkg and paste it
into your Nuget repository directory. Click OK.

3.

In Visual Studio, select Project > Manage Nuget Packages > Settings > Package Manager > Package Sources.

4.

Click the plus sign+. Enter the path that contains InterSystems.Data.Entity6.4.5.0.0.nupkg. Click OK
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Connecting to the InterSystems Database
This chapter describes how to create a connection between your client application and an InterSystems server using a
IRISConnection object.

2.1 Creating a Connection
The code below establishes a connection to a namespace named USER. See “Connection Parameters ” for a complete list
of parameters that can be set when instantiating a connection object.
The following simple method could be called to start a connection:
Add code to Instantiate the connection
public IRISConnection Conn;
private void CreateConnection(){
try {
Conn = new IRISConnection();
Conn.ConnectionString =
"Server=localhost; Port=51773; Namespace=USER;"
+ "Password=SYS; User ID=_SYSTEM;";
Conn.Open();
}
catch (Exception eConn){
MessageBox.Show("CreateConnection error: " + eConn.Message);
}
}

This example defines the IRISConnection object as a global that can be used anywhere in the program. Once the object has
been created, it can be shared among all the classes that need it. The connection object can be opened and closed as necessary.
You can do this explicitly by using Conn.Open() and Conn.Close(). If you are using an ADO.NET Dataset, instances of
DataAdapter will open and close the connection automatically, as needed.
You can also prompt the user for a connection string. The previous example could be rewritten as follows:
Use the IRISConnection.ConnectDlg() Method
private void CreateConnection(){
try {
Conn = new IRISConnection();
Conn.ConnectionString = IRISConnection.ConnectDlg();
Conn.Open();
}
...

The ConnectDlg() method displays the standard InterSystems connection dialog and returns the user's input as a connection
string.

Using the InterSystems Managed Provider for .NET
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2.2 Shared Memory Connections
The standard ADO .NET connection to a remote InterSystems IRIS instance is over TCP/IP. To maximize performance,
InterSystems IRIS also offers a shared memory connection for .NET applications running on the same machine as an
InterSystems IRIS instance. This connection avoids potentially expensive calls into the kernel network stack, providing
optimal low latency and high throughput for .NET operations.
If a connection specifies server address localhost or 127.0.0.1, shared memory will be used by default. TCP/IP will
be used if the actual machine address is specified. The connection will automatically fall back to TCP/IP if the shared
memory device fails or is not available.
Shared memory can be disabled in the connection string by setting the SharedMemory property to false. For example,
the following connection string will not use shared memory, even though the server address is specified as localhost.
"Server=localhost;Port=51773;Namespace=user;Password = SYS;User ID = _system;SharedMemory=false"

Shared memory is not used for SSL connections. The log will include information on whether a shared memory connection
was attempted and if it was successful (see the LOGFILE entry in “Other Connection Parameters ”).
Note:

Shared memory connections do not work across container boundaries
InterSystems does not currently support shared memory connections between two different containers. If a client
tries to connect across container boundaries using localhost or 127.0.0.1, the connection mode will default
to shared memory, causing it to fail. This applies regardless of whether the Docker --network host option is
specified. You can guarantee a TCP/IP connection between containers either by specifying the actual hostname
for the server address, or by disabling shared memory in the connection string (as demonstrated above).
Shared memory connections can be used without problems when the server and client are in the same container.

2.3 Connection Pooling
Connection pooling is on by default. The following connection string parameters can be used to control various aspects of
connection pooling:
•

Pooling — Defaults to true. Set Pooling to false to create a connection with no connection pooling.

•

Max Pool Size and Min Pool Size — Default values are 0 and 100. Set these parameters to specify the maximum

and minimum (initial) size of the connection pool for this specific connection string.
•

Connection Reset and Connection Lifetime — Set Connection Reset to true to turn on the pooled
connection reset mechanism. Connection Lifetime specifies the number of seconds to wait before resetting an
idle pooled connection. The default value is 0.

For example, the following connect string sets the initial size of the connection pool to 2 and the maximum number of
connections to 5, and activates connection reset with a maximum connection idle time of 3 seconds:
Conn.ConnectionString =
"Server = localhost;"
+ " Port = 51773;"
+ " Namespace = USER;"
+ " Password = SYS;"
+ " User ID = _SYSTEM;"
+ " Min Pool Size = 2;"
+ " Max Pool Size = 5;"
+ " Connection Reset = true;"
+ " Connection Lifetime = 3;";
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The IRISConnection class also includes the following static methods that can be used to control pooling:
ClearPool(conn)
IRISConnection.ClearPool(conn);

Clears the connection pool associated with connection conn.
ClearAllPools()
IRISConnection.ClearAllPools();

Removes all connections in the connection pools and clears the pools.

2.3.1 Using the IRISPoolManager Class
The IRISClient.IRISPoolManager class can be used to monitor and control connection pooling programmatically. The following static methods are available:
ActiveConnectionCount
int count = IRISPoolManager.ActiveConnectionCount;

Total number of established connections in all pools. Count includes both idle and in-use connections.
IdleCount()
int count = IRISPoolManager.IdleCount();

Total number of idle connections in all the pools.
IdleCount(conn)
int count = IRISPoolManager.IdleCount(conn);

Total number of idle connections in the pool associated with connection object conn.
InUseCount()
int count = IRISPoolManager.InUseCount();

Total number of in-use connections in all pools.
InUseCount(conn)
int count = IRISPoolManager.InUseCount(conn);

Total number of in-use connections in the pool associated with connection object conn.
RecycleAllConnections(Boolean)
IRISPoolManager.RecycleAllConnections(bool remove);

Recycles connections in all pools
RecycleConnections(conn, Boolean)
IRISPoolManager.RecycleConnections(conn,bool remove)

Recycles connections in the pool associated with connection object conn.

Using the InterSystems Managed Provider for .NET
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RemoveAllIdleConnections()
IRISPoolManager.RemoveAllIdleConnections();

Removes idle connections from all connection pools.
RemoveAllPoolConnections()
IRISPoolManager.RemoveAllPoolConnections();

Deletes all connections and removes all pools, regardless of what state the connections are in.

2.4 Server Configuration
Very little configuration is required to use a .NET client with an InterSystems server process. This section describes the
server settings required for a connection, and some troubleshooting tips.
Every .NET client that wishes to connect to an InterSystems server needs the following information:
•

A URL that provides the server IP address, port number, and namespace.

•

A case-sensitive username and password.

Check the following points if you have any problems:
•

Make sure that the server process is installed and running.

•

Make sure that you know the IP address of the machine on which the server process is running.

•

Make sure that you know the TCP/IP port number on which the server is listening.

•

Make sure that you have a valid username and password to use to establish a connection. (You can manage usernames
and passwords using the Management Portal: System Administration > Security > Users).

•

Make sure that your connection URL includes a valid namespace. This should be the namespace containing the classes
and data your program uses.

2.5 Connection Parameters
The following tables describe all parameters that can be used in a connection string.

2.5.1 Required Parameters
The following parameters are required for all connection strings (see “ Creating a Connection ”).
SERVER
IP address or host name. For example: Server = localhost
alternate names: ADDR, ADDRESS, DATA SOURCE, NETWORK ADDRESS
PORT
Specifies the TCP/IP port number for the connection. For example: Port = 51773
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NAMESPACE
Specifies the namespace to connect to. For example: Namespace = USER
alternate names: INITIAL CATALOG, DATABASE
PASSWORD
User's password. For example: Password = SYS
alternate name: PWD
USER ID
Set user login name. For example: User ID = _SYSTEM
alternate names: USER, UID

2.5.2 Connection Pooling Parameters
The following parameters define various aspects of connection pooling (see “Connection Pooling ”).
CONNECTION LIFETIME
The length of time in seconds to wait before resetting an idle Pooled connection when the connection reset
mechanism is on. Default is 0.
CONNECTION RESET
Turn on Pooled connection reset mechanism (used with CONNECTION LIFETIME). Default is false.
MAX POOL SIZE
Maximum size of connection pool for this specific connection string. Default is 100.
MIN POOL SIZE
Minimum or initial size of the connection pool, for this specific connection string. Default is 0.
POOLING
Turn on connection pooling. Default is true.

2.5.3 Other Connection Parameters
The following optional parameters can be set if required.
APPLICATION NAME
Sets the application name.
CONNECTION TIMEOUT
Sets the length of time in seconds to try and establish a connection before failure. Default is 30.
alternate name: CONNECT TIMEOUT
CURRENT LANGUAGE
Sets the language for this process.
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LOGFILE
Turns on logging and sets the log file location.
alternate name: LOG FILE.
PACKET SIZE
Sets the TCP Packet size. Default is 1024.
PREPARSE IRIS SIZE
Sets an upper limit to the number of SQL commands that will be held in the preparse cache before recycling is
applied. Default is 200.
SHAREDMEMORY
Enables or disables shared memory connections on localhost or 127.0.0.1. For example:
SharedMemory=false disables shared memory. Default is true.
SO RCVBUF
Sets the TCP receive buffer size. Default is 0 (use system default value).
alternate name: SO_RCVBUF
SO SNDBUF
Sets the TCP send buffer size. Default is 0 (use system default value).
alternate name: SO_SNDBUF
SSL
Specifies whether SSL/TLS secures the client-server connection (see “Configuring .NET Clients to Use SSL/TLS
with InterSystems IRIS ” in the Security Administration Guide). Default is false.
TCP NODELAY
Sets the TCP nodelay option. Default is true.
alternate name: TCP_NODELAY
TRANSACTION ISOLATION LEVEL
Sets the System.Data.IsolationLevel value for the connection.
alternate name: TRANSACTIONISOLATIONLEVEL
WORKSTATION ID
Sets the Workstation name for process identification.
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Using ADO.NET Managed Provider
Classes
The InterSystems ADO.NET Managed Provider allows your .NET projects to access InterSystems databases with fully
compliant versions of generic ADO.NET Managed Provider classes such as Connection, Command, CommandBuilder,
DataReader, and DataAdapter. The following classes are InterSystems-specific implementations of the standard ADO.NET
Managed Provider classes:
•

IRISConnection — Represents the connection between your application and the databases in a specified InterSystems
namespace. See “Connecting to the InterSystems Database ” for a detailed description of how to use IRISConnection.

•

IRISCommand — Encapsulates an SQL statement or stored procedure to be executed against databases in the namespace
specified by a IRISConnection.

•

IRISCommandBuilder — Automatically generates SQL commands that reconcile a database with changes made by

objects that encapsulate a single-table query.
•

IRISDataReader — Provides the means to fetch the result set specified by a IRISCommand. A IRISDataReader object

provides quick forward-only access to the result set, but is not designed for random access.
•

IRISDataAdapter — Encapsulates a result set that is mapped to data in the namespace specified by a IRISConnection.
It is used to fill an ADO.NET DataSet and to update the database, providing an effective random access connection

to the resultset.
This chapter gives some concrete examples of code using InterSystems ADO.NET Managed Provider classes. The following
subjects are discussed:
•

Introduction to ADO.NET Managed Provider Classes — provides a simple demonstration of how InterSystems
ADO.NET Managed Provider classes are used.

•

Using IRISCommand and IRISDataReader — demonstrates how to execute a simple read-only query.

•

Using SQL Queries with IRISParameter — demonstrates passing a parameter to a query.

•

Using IRISDataAdapter and IRISCommandBuilder — changing and updating data.

•

Using Transactions — demonstrates how to commit or rollback transactions.

Using the InterSystems Managed Provider for .NET
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3.1 Introduction to ADO.NET Managed Provider Classes
A project using the InterSystems implementations of ADO.NET Managed Provider classes can be quite simple. Here is a
complete, working console program that opens and reads an item from the Sample.Person database:
using System;
using InterSystems.Data.IRISClient;
using InterSystems.Data.IRISTypes;
namespace TinySpace {
class TinyProvider {
[STAThread]
static void Main(string[] args) {
IRISConnection Conn = new IRISConnection();
Conn.ConnectionString = "Server = localhost; "
+ "Port = 51773; " + "Namespace = USER; "
+ "Password = SYS; " + "User ID = _SYSTEM;";
Conn.Open();
string SQLtext = "SELECT * FROM Sample.Person WHERE ID = 1";
IRISCommand Command = new IRISCommand(SQLtext, Conn);
IRISDataReader Reader = Command.ExecuteReader();
while (Reader.Read()) {
Console.WriteLine("TinyProvider output: \r\n
"
+ Reader[Reader.GetOrdinal("ID")] + ": "
+ Reader[Reader.GetOrdinal("Name")]);
};
Reader.Close();
Command.Dispose();
Conn.Close();
} // end Main()
} // end class TinyProvider
}

This project contains the following important features:
•

The Using statements provide access to the IRISClient assembly:
using InterSystems.Data.IRISClient;
using InterSystems.Data.IRISTypes;

•

The IRISConnection object is used to create and open a connection to the USER namespace:
IRISConnection Conn = new IRISConnection();
Conn.ConnectionString = "Server = localhost; "
+ "Port = 51773; " + "Namespace = USER; "
+ "Password = SYS; " + "User ID = _SYSTEM;";
Conn.Open();

•

The IRISCommand object uses the IRISConnection object and an SQL statement to open the instance of Sample.Person
that has an ID equal to 1.
string SQLtext = "SELECT * FROM Sample.Person WHERE ID = 1";
IRISCommand Command = new IRISCommand(SQLtext, Conn);

•

The IRISDataReader object is used to access the data items in the row:
IRISDataReader Reader = Command.ExecuteReader();
while (Reader.Read()) {
Console.WriteLine("TinyProvider output: \r\n
"
+ Reader[Reader.GetOrdinal("ID")] + ": "
+ Reader[Reader.GetOrdinal("Name")]);
};
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3.2 Using IRISCommand and IRISDataReader
Simple read-only queries can be performed using only IRISCommand and IRISDataReader. Like all database transactions,
such queries also require an open IRISConnection object.
In this example, an SQL query string is passed to a new IRISCommand object, which will use the existing connection:
string SQLtext = "SELECT * FROM Sample.Person WHERE ID < 10";
IRISCommand Command = new IRISCommand(SQLtext, Conn);

Results of the query are returned in a IRISDataReader object. Properties are accessed by referring to the names of columns
specified in the SQL statement.
IRISDataReader reader = Command.ExecuteReader();
while (reader.Read()) {
Display.WriteLine(
reader[reader.GetOrdinal("ID")] + "\t"
+ reader[reader.GetOrdinal("Name")] + "\r\n\t"
+ reader[reader.GetOrdinal("Home_City")] + " "
+ reader[reader.GetOrdinal("Home_State")] + "\r\n");
};

The same report could be generated using column numbers instead of names. Since IRISDataReader objects can only read
forward, the only way to return to beginning of the data stream is to close the reader and reopen it by executing the query
again.
reader.Close();
reader = Command.ExecuteReader();
while (reader.Read()) {
Display.WriteLine(
reader[0] + "\t"
+ reader[4] + "\r\n\t"
+ reader[7] + " "
+ reader[8] + "\n");
}

3.3 Using SQL Queries with IRISParameter
The IRISParameter object is required for more complex SQL queries. The following example selects data from all rows
where Name starts with a string specified by the IRISParameter value:
string SQLtext =
"SELECT ID, Name, DOB, SSN "
+ "FROM Sample.Person "
+ "WHERE Name %STARTSWITH ?"
+ "ORDER BY Name";
IRISCommand Command = new IRISCommand(SQLtext, Conn);

The parameter value is set to get all rows where Name starts with A, and the parameter is passed to the IRISCommand object:
IRISParameter Name_param =
new IRISParameter("Name_col", IRISDbType.NVarChar);
Name_param.Value = "A";
Command.Parameters.Add(Name_param);

Note:

Be default, the SQL statement is not validated before being executed on the Server, since this would require two
calls to the Server for each query. If validation is desirable, call IRISCommand.Prepare() to validate the syntax
for the SQL statement against the server.

A IRISDataReader object can access the resulting data stream just as it did in the previous example:

Using the InterSystems Managed Provider for .NET
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IRISDataReader reader = Command.ExecuteReader();
while (reader.Read()) {
Display.WriteLine(
reader[reader.GetOrdinal("ID")] + "\t"
+ reader[reader.GetOrdinal("Name")] + "\r\n\t"
+ reader[reader.GetOrdinal("DOB")] + " "
+ reader[reader.GetOrdinal("SSN")] + "\r\n");
};

3.4 Using IRISDataAdapter and IRISCommandBuilder
The IRISCommand and IRISDataReader classes are inadequate when your application requires anything more than
sequential, read-only data access. In such cases, the IRISDataAdapter and IRISCommandBuilder classes can provide full
random read/write access. The following example uses these classes to get a set of Sample.Person rows, read and change
one of the rows, delete a row and add a new one, and then save the changes to the database.
The IRISDataAdapter constructor accepts an SQL command and a IRISConnection object as parameters, just like a
IRISCommand. In this example, the resultset will contain data from all Sample.Person rows where Name starts with A or
B. The Adapter object will map the resultset to a table named Person:
string SQLtext =
" SELECT ID, Name, SSN "
+ " FROM Sample.Person "
+ " WHERE Name < 'C' "
+ " ORDER BY Name ";
IRISDataAdapter Adapter = new IRISDataAdapter(SQLtext, Conn);
Adapter.TableMappings.Add("Table", "Person");

A IRISCommandBuilder object is created for the Adapter object. When changes are made to the data mapped by the
Adapter object, Adapter can use SQL statements generated by Builder to update corresponding items in the database:
IRISCommandBuilder Builder = new IRISCommandBuilder(Adapter);

An ADO DataSet object is created and filled by Adapter. It contains only one table, which is used to define the
PersonTable object.
System.Data.DataSet DataSet = new System.Data.DataSet();
Adapter.Fill(DataSet);
System.Data.DataTable PersonTable = DataSet.Tables["Person"];

A simple foreach command can be used to read each row in PersonTable. In this example, we save Name in the first
row and change it to "Fudd, Elmer". When the data is printed, all names will be in alphabetical order except the first,
which now starts with F. After the data has been printed, the first Name is reset to its original value. Both changes were
made only to the data in DataSet. The original data in the database has not yet been touched.
if (PersonTable.Rows.Count > 0) {
System.Data.DataRow FirstPerson = PersonTable.Rows[0];
string OldName = FirstPerson["Name"].ToString();
FirstPerson["Name"] = "Fudd, Elmer";
foreach (System.Data.DataRow PersonRow in PersonTable.Rows) {
Display.WriteLine("\t"
+ PersonRow["ID"] + ":\t"
+ PersonRow["Name"] + "\t"
+ PersonRow["SSN"]);
}
FirstPerson["Name"] = OldName;
}

The following code marks the first row for deletion, and then creates and adds a new row. Once again, these changes are
made only to the DataSet object.
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FirstPerson.Delete();
System.Data.DataRow NewPerson = PersonTable.NewRow();
NewPerson["Name"] = "Budd, Billy";
NewPerson["SSN"] = "555-65-4321";
PersonTable.Rows.Add(NewPerson);

Finally, the Update() method is called. Adapter now uses the IRISCommandBuilder code to update the database with the
current data in the DataSet object's Person table.
Adapter.Update(DataSet, "Person");

3.5 Using Transactions
The Transaction class is used to specify an SQL transaction (see “Transaction Processing ” in Using InterSystems SQL for
an overview of how to use transactions). In the following example, transaction Trans will fail and be rolled back if SSN
is not unique.
IRISTransaction Trans =
Conn.BeginTransaction(System.Data.IsolationLevel.ReadCommitted);
try {
string SQLtext = "INSERT into Sample.Person(Name, SSN) Values(?,?)";
IRISCommand Command = new IRISCommand(SQLtext, Conn, Trans);
IRISParameter Name_param =
new IRISParameter("name", IRISDbType.NVarChar);
Name_param.Value = "Rowe, Richard";
Command.Parameters.Add(Name_param);
IRISParameter SSN_param =
new IRISParameter("ssn", IRISDbType.NVarChar);
SSN_param.Value = "234-56-3454";
Command.Parameters.Add(SSN_param);
int rows = Command.ExecuteNonQuery();
Trans.Commit();
Display.WriteLine("Added record for " + SSN_param.Value.ToString());
}
catch (Exception eInsert) {
Trans.Rollback();
WriteErrorMessage("TransFail", eInsert);
}
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Using the Entity Framework Provider
Entity Framework is an object-relational mapper that enables .NET developers to work with relational data using domainspecific objects. It eliminates the need for most of the data-access code that developers usually need to write. The InterSystems
Entity Framework Provider enables you to use Entity Framework 6 technology to access an InterSystems database (if you
are using Entity Framework 5, ask your InterSystems representative for instructions). For more information on the .NET
Entity Framework, see http://www.asp.net/entity-framework.
See “Setting Up Entity Framework Provider” in the Introduction chapter for information on Entity Framework system
requirements, installation, and setup.
This chapter describes three approaches to getting started with Entity Framework:
•

Code First — Start by defining data classes and generate a database from the class properties.

•

Database First — Start with an existing database, then use Entity Framework to generate code for a web application
based on the fields of that database.

•

Model First — Start by creating a database model showing entities and relationships, then generate a database from
the model.

The sections below show examples of each of these approaches.

4.1 Code First
This section shows an example of how to write code to define data classes and then generate tables from the class properties.
The example in this section is based on the Entity Framework Tutorial from EntityFrameworkTutorial.net
(http://www.entityframeworktutorial.net/code-first/simple-code-first-example.aspx).
1.

Create a new project in Visual Studio 2013 with FILE > New > Project. With a Template of Visual C# and Console
Application highlighted, enter a name for your project, such as CodeStudents. Click OK

2.

Add InterSystems Entity Framework Provider to the project: Click TOOLS > Nuget Package Manager > Manage Nuget
Packages for Solution. Expand Online > Package Source. InterSystems Entity Framework Provider 6 is displayed. Click
Install > Ok > I Accept. Wait for the installation to complete and then click Close.

3.

Compile the project with Build > Build Solution.

4.

Tell the project which system to connect to by identifying it in the App.config file as follows. From the Solution Explorer
window, open the App.config file. Add a <connectionStrings> section (like the example shown here) as the last
section in the <configuration> section after the <entityFramework> section.
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Note:

Check that the server, port, namespace, username, and password are correct for your configuration.

<connectionStrings>
<add
name="SchoolDBConnectionString"
connectionString="SERVER = localhost;
NAMESPACE = USER;
port=51773;
METADATAFORMAT = mssql;
USER = _SYSTEM;
password = SYS;
LOGFILE = C:\\Users\\Public\\logs\\cprovider.log;
SQLDIALECT = iris;"
providerName="InterSystems.Data.IRISClient"
/>
</connectionStrings>

5.

In the Program.cs file, add
using System.Data.Entity;
using System.Data.Entity.Validation;
using System.Data.Entity.Infrastructure;

6.

Define classes:
public class Student
{
public Student()
{
}
public int StudentID { get; set; }
public string StudentName { get; set; }
public DateTime? DateOfBirth { get; set; }
public byte[] Photo { get; set; }
public decimal Height { get; set; }
public float Weight { get; set; }
public Standard Standard { get; set; }
}
public class Standard
{
public Standard()
{
}
public int StandardId { get; set; }
public string StandardName { get; set; }
public ICollection<Student> Students { get; set; }
}
public class SchoolContext : DbContext
{
public SchoolContext() : base("name=SchoolDBConnectionString")
{
}
public DbSet<Student> Students { get; set; }
public DbSet<Standard> Standards { get; set; }
}

Check that class SchoolContext points to your connection in App.config.
7.

Add code to Main.
using (var ctx = new SchoolContext())
{
Student stud = new Student() { StudentName = "New Student" };
ctx.Students.Add(stud);
ctx.SaveChanges();
}

8.

Compile and run.

Check the namespace (USER in this case). You see three tables created: dbo.Standards, dbo.Students (which has a new
student added), and dbo._MigrationHistory (which holds information about table creation).
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4.2 Database First
For instructions on how to set up the database used in the following examples, see “Setting Up a Sample Database ” at the
end of this chapter.
To use the database first approach, start with an existing database and use Entity Framemaker to generate code for a web
application based on the fields of that database.
1.

Create a new project in Visual Studio 2013 with FILE > New > Project of type Visual C# > Console Application > OK.

2.

Click TOOLS > Nuget Package Manager > Manage Nuget Packages for Solution. Expand Online > Package Source,
which lists InterSystems Entity Framework Provider 6. Click Install > Ok > Accept the license > Close.

3.

Compile the project with Build > Build Solution.

4.

Select PROJECT > Add New Item > Visual C# Items > Ado.NET Entity Data Model. You can give your model a name.
Here we use the default of Model1. Click Add.

5.

In the Entity Data Model Wizard:

6.

a.

Select EF Designer from database > Next

b.

In the Choose Your Data Connection screen, the data connection field should already be to your Northwind database.
It doesn’t matter whether you select Yes, Include or No, exclude to the sensitive data question.

c.

On the bottom of screen you can define a connection settings name. The default is localhostEntities. This
name is used later on.

d.

In the Choose Your Database Objects and Settings screen, answer the question Which Database objects do you
want to include in your model? by selecting all objects: Tables, Views, and Stored Procedures and
Functions. This includes all Northwind tables.

e.

Click Finish.

f.

In several seconds, you’ll see a Security Warning. Click OK to run the template.

g.

Visual Studio may display an Error List with many warnings. You can ignore these.

For a model name of Model1, Visual Studio generates multiple files under Model1.edmx – including a UI diagram as
Model1.edmx itself, classes representing tables under Model1.tt, and context class localhostEntities in
Model1.Context.tt->Model1.Context.cs.
In the Solution Explorer window, you can inspect Model1.Context.cs. The constructor Constructer public
localhostEntities() : base("name=localhostEntities") points to App.Config connection string:
<connectionStrings>
<add
name="localhostEntities"
connectionString="metadata=res://*/Model1.csdl|
res://*/Model1.ssdl|
res://*/Model1.msl;provider=InterSystems.Data.IRISClient;
provider connection string=&quot;
ApplicationName=devenv.exe;
ConnectionLifetime=0;
ConnectionTimeout=30;
ConnectionReset=False;
Server=localhost;
Namespace=NORTHWINDEF;
IsolationLevel=ReadUncommitted;
LogFile=C:\Users\Public\logs\cprovider.log;
MetaDataFormat=mssql;
MinPoolSize=0;
MaxPoolSize=100;
Pooling=True;
PacketSize=1024;
Password=SYS;
Port=51773;

Using the InterSystems Managed Provider for .NET

21

Using the Entity Framework Provider
PreparseIrisSize=200;
SQLDialect=iris;
Ssl=False;
SoSndBuf=0;
SoRcvBuf=0;
StreamPrefetch=0;
TcpNoDelay=True;
User=_SYSTEM;
WorkstationId=DMITRY1&quot;"
providerName="System.Data.EntityClient"
/>
</connectionStrings>

7.

Compile your project with BUILD > Build Solution.

Below are two examples that you can paste into Main() in Program.cs:
You can traverse a list of customers using:
using (var context = new localhostEntities()) {
var customers = context.Customers;
foreach (var customer in customers) {
string s = customer.CustomerID + '\t' + customer.ContactName;
}
}

You can get a list of orders for CustomerID using:
using (var context = new localhostEntities()) {
var customerOrders = from c in context.Customers
where (c.CustomerID == CustomerID)
select new { c, c.Orders };
foreach (var order in customerOrders) {
for (int i = 0 ; i < order.Orders.Count; i++) {
var orderElement = order.Orders.ElementAt(i);
string sProduct = "";
//Product names from OrderDetails table
for (int j = 0; j < orderElement.OrderDetails.Count; j++)
{
var product = orderElement.OrderDetails.ElementAt(j);
sProduct += product.Product.ProductName;
sProduct += ",";
}
string date = orderElement.OrderDate.ToString();
}
}
}

4.3 Model First
Use the model first approach by generating a database model based on the diagram you created in the “Database First ”
section. Then generate a database from the model.
This example shows you how to create a database that contains two entities,
1.

Look at the Entity Framework UI edmx diagram Model1.edmx. In a blank area of the diagram, right-click and select
Properties.

2.

Change DDL Generation Template to SSDTLtoIrisSQL.tt.

3.

Compile Project.

4.

In a blank area of the diagram, right-click and select Generate Database From Model. After the DDL is generated, click
Finish.

5.

Studio creates and opens the file Model1.edmx.sql.

6.

Import your table definitions into InterSystems by executing the following command in a terminal:
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do $SYSTEM.SQL.DDLImport("MSSQL","_system","C:\\<myPath>\\Model1.edmx.sql")

4.4 Setting Up a Sample Database
If you want to set up a sample database for use with the “Database First ” section, follow the steps in this section. These
steps set up and load the sample database CreateNorthwindEFDB.sql.
1.

In the Management Portal, select System > Configuration > Namespaces and click Create New Namespace.

2.

Name your namespace NORTHWINDEF.

3.

4.

5.

a.

For Select an Existing Database for Globals, click Create New Database. Enter NORTHWINDEF as the database
and <installdir>\mgr\EFdatabase as the directory. Click Next and Finish

b.

For Select an Existing Database for Routines, select NORTHWINDEF from the dropdown list.

c.

Click Save.

In the Management Portal, select System > Configuration > SQL and Object Settings > General SQL Settings.
a.

In the SQL tab, enter the Default SQL Schema Name as dbo.

b.

In the SQL tab, select Support Delimited Identifiers (default is on)

c.

In the DDL tab, select all items.

d.

Click Save.

Select System > Configuration > SQL and Object Settings > TSQL Compatability Settings
a.

Set the DIALECT to MSSQL.

b.

Set QUOTED_IDENTIFIER to ON.

c.

Click Save.

In a Terminal window, change to your new namespace with
zn “NORTHWINDEF”

6.

If this is not the first time you are setting up the database, purge existing data with:
do $SYSTEM.OBJ.DeleteAll("e") d Purge^%apiSQL()

7.

If you have not already done so, using an unzip program, extract files from installdir\dev\dotnet\bin\v4.0.30319\IrisEF.zip
to a folder called IrisEF.

8.

To load the ddl, enter
do
$SYSTEM.SQL.DDLImport("MSSQL","_system","<installdir>\dev\dotnet\bin\v4.0.30319\IrisEF\CreateNorthwindEFDB.sql")

In the Server Explorer window, you can expand the InterSystems server entry to view NorthwindEF database elements:
Tables, Views, Function, Procedures. You can examine each element, retrieve Data for Tables and Views, Execute Functions
and Procedures. If you right-click an element and select Edit, Studio opens showing corresponding class and position on
requested element if applicable.
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