Using InterSystems Development Environments — Atelier and Studio
Contents
 
   
Server:docs2
Instance:LATEST
User:UnknownUser
 
-
Go to:
Search:    

 
Contents

Preface : 
 
 
Chapter 1: 
 
Chapter 2: 
 
  • 2.1 Overview of the Studio Window
  • 2.1.1 Running Studio from the Command Line
  • 2.2 Projects
  • 2.3 Class Definitions
  • 2.3.1 Class Definitions as Text
  • 2.4 CSP Files
  • 2.5 Routine Editor
  • 2.6 Multiple User Support
  • 2.7 Importing and Exporting Caché Documents Locally
  • 2.8 Debugging
  • 2.8.1 Debugging Object-Based Applications
  • 2.9 Integration with Caché Security
  • 2.10 Source Control Hooks
  • Chapter 3: 
     
  • 3.1 Creating a Project
  • 3.2 Creating a Database
  • 3.2.1 Defining a New Class
  • 3.2.2 Adding Properties
  • 3.2.3 Saving and Compiling Your Class
  • 3.2.4 Viewing Documentation for Your Class
  • 3.3 Creating a Web User Interface using CSP
  • 3.3.1 Creating a CSP File
  • 3.3.2 Saving and Compiling Your CSP File
  • 3.3.3 Viewing Your Web Page
  • 3.4 Creating a Web User Interface using Zen
  • 3.4.1 Making Your Class a Data Adaptor
  • 3.4.2 Creating a Zen Page
  • 3.4.3 Adding a Zen Form
  • 3.4.4 Adding Client-side Methods
  • 3.4.5 Viewing the Database in a Table
  • Chapter 4: 
     
  • 4.1 Creating New Class Definitions
  • 4.1.1 New Class Wizard
  • 4.1.2 Results of Running the New Class Wizard
  • 4.2 Opening Class Definitions
  • 4.3 Editing Class Definitions
  • 4.4 Saving and Deleting Class Definitions
  • 4.5 Compiling Class Definitions
  • 4.5.1 Incremental Compilation
  • 4.6 Renaming Class Definitions
  • 4.7 Class Inspector
  • 4.7.1 Activating the Class Inspector
  • 4.8 Class Browser
  • 4.9 Superclass Browser and Derived Class Browser
  • 4.9.1 Superclass Browser
  • 4.9.2 Derived Class Browser
  • 4.10 Package Information
  • Chapter 5: 
     
  • 5.1 New Property Wizard
  • 5.1.1 Name and Description Page
  • 5.1.2 Property Type Page
  • 5.1.3 Property Characteristics Page
  • 5.1.4 Data Type Parameters Page
  • 5.1.5 Property Accessors Page
  • 5.1.6 Results of Running the New Property Wizard
  • Chapter 6: 
     
  • 6.1 New Method Wizard
  • 6.1.1 Name and Description Page
  • 6.1.2 Method Signature Page
  • 6.1.3 Method Characteristics Page
  • 6.1.4 Implementation Page
  • 6.1.5 Results of Running the New Method Wizard
  • 6.2 Overriding a Method
  • Chapter 7: 
     
  • 7.1 New Class Parameter Wizard
  • Chapter 8: 
     
  • 8.1 New Property Wizard to Create a Relationship Property
  • 8.1.1 Name and Description Page
  • 8.1.2 Property Type Page
  • 8.1.3 Relationship Characteristics Page
  • 8.1.4 Additional Changes
  • 8.1.5 Results of Creating a New Relationship with the New Property Wizard
  • Chapter 9: 
     
  • 9.1 New Query Wizard
  • 9.1.1 Name, Implementation, and Description Page
  • 9.1.2 Input Parameters Page
  • 9.1.3 Columns Page
  • 9.1.4 Conditions Page
  • 9.1.5 Order By Page
  • 9.1.6 Row Specification Page
  • 9.1.7 Results of Running the New Query Wizard
  • Chapter 10: 
     
  • 10.1 New Index Wizard
  • 10.1.1 Name and Description Page
  • 10.1.2 Index Type Page
  • 10.1.3 Index Properties Page
  • 10.1.4 Index Data Page
  • 10.1.5 Results of Running the New Index Wizard
  • 10.2 Populating an Index
  • Chapter 11: 
     
  • 11.1 New Projection Wizard
  • 11.1.1 Name and Description Page
  • 11.1.2 Projection Type Page
  • 11.1.3 Results of Running the New Projection Wizard
  • Chapter 12: 
     
  • 12.1 New XData Wizard
  • Chapter 13: 
     
  • 13.1 SQL Aliases
  • 13.2 SQL Stored Procedures
  • 13.2.1 Query-Based Stored Procedure
  • 13.2.2 Creating Method-Based Stored Procedure
  • 13.3 Adding SQL Triggers to a Class
  • 13.3.1 New SQL Trigger Wizard
  • 13.4 Adding New SQL Foreign Keys to a Class
  • 13.4.1 New SQL Foreign Key Wizard
  • Chapter 14: 
     
  • 14.1 Adding Storage Definitions to a Class
  • 14.1.1 Using the New Storage Wizard
  • 14.2 Using the Class Inspector with Storage Definitions
  • 14.3 Using the Class Editor with Storage Definitions
  • Chapter 15: 
     
  • 15.1 Sample CSP Page
  • 15.2 Creating a New CSP File
  • 15.2.1 Default.csp Template File
  • 15.3 Editing a CSP File
  • 15.3.1 Insert Options
  • 15.4 Saving a CSP File
  • 15.5 Compiling a CSP File
  • 15.6 Viewing the Results of a CSP File
  • 15.7 Viewing Syntax-Colored Source for Any URL
  • Chapter 16: 
     
  • 16.1 Routine Editor
  • 16.2 Routine Source Formats
  • 16.3 Creating a New Routine or Include File
  • 16.4 Opening an Existing Routine or Include File
  • 16.5 Routine Template File
  • 16.6 Saving, Compiling, and Deleting Routines
  • 16.7 Save Automatically Backs Up Routines, Include, and CSP Files
  • Chapter 17: 
     
  • 17.1 Sample Debugging Session: Debugging a Routine
  • 17.2 Debugger Settings for the Current Project
  • 17.2.1 Debug Target
  • 17.2.2 Breakpoints
  • 17.3 Debug Menu
  • 17.4 Watch Window
  • 17.4.1 Debugger Watch Window Context Menu
  • Chapter 18: 
     
  • 18.1 Accessing Studio Templates
  • 18.2 Caché-Supplied Standard Studio Templates
  • 18.2.1 Templates
  • 18.2.2 Class Definition Templates
  • 18.2.3 Zen Templates
  • 18.2.4 Add-In Templates
  • 18.3 Making Your Own Studio Templates
  • 18.3.1 Template Architecture
  • 18.3.2 Default Template Timeout
  • 18.3.3 Simple Text Templates
  • 18.3.4 Interactive Studio Templates
  • 18.3.5 New Document Studio Templates
  • 18.3.6 Add Text to End of a Document
  • 18.3.7 Add-in Studio Templates
  • Chapter 19: 
     
  • 19.1 File Menu
  • 19.2 Edit Menu
  • 19.2.1 Basic Editing
  • 19.2.2 Find and Replace
  • 19.2.3 Bookmarks
  • 19.2.4 Advanced Editing
  • 19.3 View Menu
  • 19.3.1 Toolbars
  • 19.3.2 Customize Toolbars
  • 19.4 Project Menu
  • 19.4.1 Common Project Tasks
  • 19.5 Class Menu
  • 19.6 Build Menu
  • 19.7 Debug Menu
  • 19.8 Tools Menu
  • 19.9 Utilities Menu
  • 19.10 Window Menu
  • 19.11 Help Menu
  • 19.12 Context Menus
  • 19.12.1 Editor Context Menu
  • 19.12.2 Workspace Context Menu
  • 19.12.3 Inspector Context Menu
  • 19.12.4 Tab Context Menu
  • 19.12.5 Window Display Context Menu
  • 19.12.6 Debugger Watch Context Menu
  • 19.13 Keyboard Accelerators
  • 19.13.1 Inserting MultiValue Characters
  • 19.14 Adding to a Studio Menu
  • Chapter 20: 
     
  • 20.1 Environment Options
  • 20.2 Editor Options
  • 20.3 Compiler Options
  • 20.4 SQL Options
  • 20.5 Studio Look Options
  •  
    Appendix A: 
     
  • A.1 Overview
  • A.2 Caché Documents
  • A.2.1 Tools for Managing Documents and Files
  • A.2.2 Deciding How to Map Internal and External Names
  • A.3 Creating and Activating a Source Control Class
  • A.3.1 Extending Studio
  • A.3.2 Creating a Source Control Class
  • A.3.3 Activating a Source Control Class
  • A.4 Accessing Your Source Control System
  • A.4.1 Example 1
  • A.4.2 Example 2
  • A.5 Sample Source Control Class
  • A.5.1 Introduction
  • A.5.2 Global
  • A.5.3 Determining the External Names
  • A.5.4 Synchronizing the Caché Document and the External File
  • A.5.5 Controlling the Status of the Caché Document
  • A.5.6 Source Control Actions
  • A.5.7 Other Details
  • Appendix B: 
     
  • B.1 Class Definition Example
  • B.2 General Structure
  • B.2.1 Generation and Format
  • B.2.2 Statements
  • B.2.3 Comments
  • B.2.4 Comments Used in the Intersystems Class Reference
  • B.3 Statements
  • B.3.1 Class Statement
  • B.3.2 Parameter Statement
  • B.3.3 Property Statement
  • B.3.4 Relationship Statement
  • B.3.5 Index Statement
  • B.3.6 Method and ClassMethod Statements
  • B.3.7 SQL Query Statement
  • B.3.8 Projection Statement
  • B.3.9 SQL Trigger Statement
  • B.3.10 SQL ForeignKey Statement
  • Appendix C: