Using InterSystems Development Environments — Atelier and Studio
Studio Menu Reference
[Home] [Back] [Next]
InterSystems: The power behind what matters   
Class Reference   
Search:    

This chapter describes menu and keyboard options available from the Studio menus. The menus are:

File Menu
The File menu contains options for opening and saving documents and projects. Options vary depending on whether a file is open. See also the section Keyboard Accelerators.”
New Studio Use to connect to a different Caché server.
Change Namespace ... Use to change to a different namespace.
New ...
Use to create a new document (such as class definition, routine, or CSP file) in an editor window. You can also drag and drop files into Studio. Document types are grouped under four tabs:
  • General - for creating a new ObjectScript routine, Caché Basic routine, Caché class definition (with the New Class wizard), Caché MultiValue routine, Web Service/Client Configuration, or Web Service.
  • CSP File - for creating a new Caché Server Page, XML file, JavaScript file, or cascading style sheet (CSS) file
  • Zen— for creating a new Zen application, component, page, report, form, or Web Service. (For details, see Zen Wizards in Using Zen.
  • Custom - for a new DeepSee KPI. For information on DeepSee KPIs, see the Advanced DeepSee Modeling Guide.
Open ....
Opens a Allows to you open an existing item from the current Caché namespace and server.
The Open dialog is displayed for the current namespace. Select a file type as needed. Select Ctrl+A to Select All.
If the item is in use by another user, you can open it for Read Only access.
To open automatically-saved backup files, see Save Automaticly Backs Up Routines, Include, and CSP Files
Studio allows you to edit class definitions, routines, and CSP files only from the current server and namespace. To open an item from a different server or namespace, use File > Change Namespace to change to a different namespace or switch to a different server. Use File > New Studio to open a second Studio window.
If you select an item and right-click Delete, the item and all subitems are deleted. Examples: if you select an .INT file, both .INT and .OBJ files are deleted. If you select a .cls file, all associated .INT and .OBJ files are deleted also.
Open URL Displays HTML source in an editor. This is useful when you are developing a Web-based application to view progress.
Close Closes the current editor.
Save Saves the contents of the current editor.
Save As ... Saves the contents of the current editor with a name that you specify.
Save All Saves the contents of all open windows.
New Project Creates a new project in the current Caché server and namespace.
Open Project ...
Opens an existing project in the current Caché server and namespace. You can also drag and drop a project into Studio.
To open a project from a different server or namespace, use File > Change Namespace to change to a different namespace or switch to a different server. Use File > New Studio to open a project in a second Studio window.
Save Project Saves setting for the current project. It does not save any modified documents belonging to the project.
Save Project As Saves the current project with a name you specify.
Close Project Closes the current project.
Print ... Prints the current document.
Print Preview Displays the document as it will look when printed.
Print Setup ... Opens the Print Setup dialog with which you can set how documents are printed.
Recent Files ... Lists recently used files. More shows files (if they exist) in categories Today, Yesterday, Last 7 days, Last 30 days and All. All is limited to 100 documents. Select Clear History to clear all. Select Open Document to open a selected document.
Recent Projects ... Lists recently used projects.
Exit Ends the current Studio session.
Edit Menu
The Edit menu contains editing and navigation options. Most of the options have keyboard shortcuts; see the section Keyboard Accelerators.”.
Basic Editing
Undo
Reverses the last action.
Note that changes made to classes with the Class Inspector cannot be reversed using Undo.
Redo Reverses the most recent Undo.
Cut Deletes the current text selection and copies it to the clipboard.
Copy Copies the current text selection to the clipboard.
Paste Inserts the contents of the clipboard at the current cursor location.
Delete Deletes the current text selection without copying it to the clipboard. If you highlight an item in the Workspace window, the item and any of its generated files are deleted.
Select All Selects all the contents of the current document.
Find and Replace
Find Searches for text in the current document. You can use wildcard matching with the * (asterisk to match any number of any character) and ? (question mark to match a single character). To find the character * or ? or \ (asterisk, question mark, or backslash) , escape it with a backslash (\). To find a tab, use \t. See the section More on Find beneath this table to specify an element type to search within and an explanation of the backslash escape.
Find In Files
Searches for text in multiple files on the Caché server. Enter a string to search for, select the type of file to search (such as .cls for class definitions), and select Find. See the section Find in Files beneath this table for specifics.
Search Searches for a class in the current project. In the Search window, type in a class name. The list shows matching entries. To open a class, double-click a class or select a row and press Enter or select GoTo.
Cancel Cancels a running Find in Files search or a class compilation.
Replace Replaces one text string with another in the current document.
Go To Moves the cursor to a location in the current document, specified as either a line number or (for routines and class definitions) a tag or class member.
Go Back After a Go To action, returns the cursor to the previous location — before the Go To action.
Bookmarks See Bookmarks below.
Advanced See Advanced
Next Error Moves the cursor to the next error in a CSP file.
Previous Error Moves the cursor to the previous error in a CSP file.
Next Warning Moves the cursor to the next warning in a file.
Previous Warning Moves the cursor to the previous warning in a file.
More on Find
Backslash Escape
The search engine normally interprets a backslash (\) as a metacharacter; that is, a character that means something other than itself. In this case — the backslash and the following character form a two-character code. When you want to search for the backslash itself, you need to create a two-character code since the search engine always looks for a second character when it sees a backslash. Create a two-character code with a second backslash. The search engine interprets this as the backslash character itself.
This convention was implemented during the development of the UNIX grep command and the convention, if not the underlying C code, has been duplicated many times since.
Match Element Type
To find text that is in a particular element type (such as a command, variable, operator, and so on), enter the desired text in the Find what field and select the Match Element Type check box.
Note:
Find displays the searched-for text in all elements of that type in the open file, regardless of language selected. In the Language field, select the language that you are interested in to limit the number of element types shown in the Element list. In the Element field, select the element type that contains the text you are looking for and select Find Next.
For example, searching for the word Set in a Comment with the Class Definition Language selected matches all instances of the word Set in comments that exist in any language in the file.
Find in Files
When you select Find in the Find in Files dialog, Studio searches the selected files in the current Caché namespace and returns a list of all (up to the first 5,000) files that contain the search string. Double-click an item in the search results to open the file and display the item, highlighted. Line & column numbers for the selected item are displayed in the right corner of the status bar.
Note that Find in Files searches stored data; it does not search modified open documents. If you search only in the current project and the current project is either a new project or a modified project, you are prompted to save the project. If you refuse, Find in Files is canceled.
Note also that to find a backslash (\) in Find in Files, you need to escape the backslash with another backslash. See the section More on Find for an explanation of the backslash escape.
The Filter field can contain the elements in the list below. You can use SQL AND and OR logical operators to enter more than one filter. For example, Type=5 AND Modified>01/01/08. The contents of the Filter field forms part of an SQL WHERE clause. The fields come from the %Studio.OpenDialogItems class.
You can enter your own custom mask in the In files/file types field, such as al*.mac. Use a comma delimited list to enter multiple filters in any field.
You can use the following items in the Filter field.
Bookmarks
You can use bookmarks to keep track of locations in your application source. Bookmarks are stored on the local machine in which Studio is running; they are not shared among multiple users. The bookmark options are:
Toggle Bookmark Adds or removes a bookmark at the current line in the current document.
Clear Bookmarks Removes all bookmarks defined for the current document.
Next Bookmark Moves the cursor to the next bookmark in the current document.
Previous Bookmark Moves the cursor to the previous bookmark in the current document.
Advanced Editing
The Advanced Editing menu contains some commands that are displayed in certain circumstances only.
Expand Commands Displays when you have an ObjectScript routine open and text is highlighted. Replaces all abbreviated ObjectScript commands contained in the currently selected text with their full names. For example, the following code:
S x = 10
Is replaced with:
Set x = 10
Compress Commands Displays when you have an ObjectScript routine open and text is highlighted. Replaces all ObjectScript commands contained in the currently selected text with their abbreviated versions. For example:
Set x = 10
Would be replaced with:
S x = 10
Increase Line Indent Increases indent for selected lines.
Decrease Line Indent Decreases indent for selected lines.
Make Uppercase Uppercases selected text.
Make Lowercase Lowercases selected text.
Comment Line Turns a selected line into a comment by adding a # (pound sign) to the beginning of the line.
Uncomment Line Turns a selected comment into a regular line by removing a # (pound sign) from the beginning of the line.
Comment Block Turns a selected block of text into a commented block by adding a /* (slash asterisk) to the beginning of the block and a */ (asterisk slash) to the end of the block..
Uncomment Block Turns a commented block of text into a regular block by removing the /* (slash asterisk) from the beginning of the block and the */ (asterisk slash) from the end of the block..
Tabify Selected Lines Adds a tab to the beginning of each of a set of selected lines.
Untabify Selected Lined Removes a tab from the beginning of each of a set of selected lines.
View Menu
The View menu contains options that control what is displayed. Which options are shown on this menu depends on where your cursor is. See also the section Keyboard Accelerators.”
Workspace Shows or hides the Workspace window. The Workspace window has three tabs:
  • Project - Displays the contents of the current project.
  • Windows - Displays a list of all current windows.
  • Namespace - Displays the contents of the current namespace.
Inspector Shows or hides the Inspector. The Inspector displays class definitions in an editable table. Some aspects of class definitions can be changed in a file only; some can be changed in a file or in the Inspector; and some can be edited only in the Inspector.
Output Shows or hides the Output window. The Output window displays output from the server (such as error messages resulting from compilation). You can enter ObjectScript commands into this window; they are executed on the server. Line & column numbers for the selected information are displayed in the right corner of the status bar.
Watch Shows or hides the Watch window. The Watch window displays watchpoints when debugging.
Toolbars Lets you select Studio toolbars to show or hide.
Full Screen Expands Studio to occupy the full screen.
Text Size Lets you Increase, return to Normal, or Decrease text size of text in Studio.
Show Special Characters Displays spaces, tabs, and end-of-line characters in the Studio Editor window.
Show Line Numbers Displays line numbers.
Reload If a document is active, reloads the saved version of current document. If the Workspace window is active, reloads the window or project. If the Workspace window, Namespace tab is active reloads the subtree parent of the selected item; highlight topmost level to reload the entire tree.
View Other Code Displays any source code generated by the compiler, such as .INT and .MAC files, related to the position of the cursor. This option works only if the current window has one or more source files currently generated for it.
View Other Documents Displays other documents related to the current document. In some situations,View Other Code results in the same behavior as View Other Documents.
Web Page
Available only when in a CSP file.
Opens your default Web browser and displays the current CSP file, so that you can see how your CSP pages will look as you develop Web applications.
You can change the network address portion of the URL used with Project > Settings. The default value is http://localhost:8972.
Expand Code Available only in some files. Displays complete code in text editor window.
Contract Code Available only in some files. Contracts some code sections in text editor window. Select the plus icon to expand a section.
Show Class Documentation Available only in class definition files or when a class is selected. Displays online documentation for the current class derived from the (saved) descriptions of class members.
Language Mode
Available only when you are in a source code file, such as .INT or .MAC.
Select from a list of Caché language versions as appropriate for your site.
Toolbars
The Toolbars menu lets you toggle the display of toolbars and lets you customize toolbars.
Standard Toggles display of the Standard toolbar.
Debug Toggles display of the Debug toolbar.
Members Toggles display of the class Members toolbar.
Status Bar Toggles display of the status bar at the bottom of the Studio window. From left to right, this bar shows a status message and the location of the cursor by line and column. The four buttons on the right, if highlighted, show that the Caps Lock key is on, that the Num Lock key is on, that the Insert key is on (Overwrite), and that the current file is a read-only file. The status bar also displays line and column numbers for Find in Files and Output windows, where appropriate.
Bookmark Toggles of the Bookmark toolbar.
Customize Opens the Customize dialog.
Toolbars, displaying text labels are shown below. To display text labels in Studio, choose View > Toolbars > Customize, the Toolbars tab. Select a toolbar and select Show text tabels. (If a toolbar is already selected, uncheck the toolbar, recheck the toolbar, and check Show text labels.)
Standard Toolbar
Debug Toolbar
Class Members Toolbar
The BPL toolbar is only applicable in Ensemble.
BPL Toolbar
Bookmarks Toolbar
Customize Toolbars
The Customize menu consists of four tabs for customizing parts of the Studio interface, Commands, Toolbars, Tools, and Options.
Commands Lists menus and all commands on Studio menus. Drag a command and drop it into an open toolbar. To remove a command from a toolbar, drag it off the toolbar.
Toolbars Select check boxes to display toolbars. Toolbars can include text labels if you select Show text labels. The Menu Bar cannot be cleared. Select New to create a new toolbar.
Tools Adds menu items to the Studio Tools menu. Specify an item name, it's command, any arguments, and it's initial directory.
Options Select check boxes to turn on the display of screen tips, screen tips including shortcut keys, and large icons.
Project Menu
The Project menu contains options for working with projects.
Add Item Adds the item in the current editor window to the current project.
Remove Item Removes the item in the current editor window from the current project.
Settings
Select to edit settings for the current project:
Common Project Tasks
To delete a project, select File > Open Project and right-click the project that you want to delete.
To import a project, select Tools > Import Local and select the .xml file that contains the project.
To export a project, open the project, select Tools > Export, select Export Current Project, browse to the output directory, and enter a file name.
Project names cannot include the characters .,;/\ (that is, period, comma, semi-colon, slash, or backslash).
Class Menu
The Class menu contains options for editing class definitions and is available only when you are in a class definition file.
The class options are arranged in an Add submenu and an Override dialog. The options include:
Add Select one of: Property, Method, Class Parameter, Query, Index, SQL Trigger, Foreign Key, Storage, Projection, or XData Opens a wizard for the item and inserts an item definition into the current class definition. See separate chapters in this book for details on options for each of these class members.
Refactor or Override
(Refactoring is available only when Studio is connected to a Windows server (it may be Override on other platforms). Some features may partially work on non-Windows platforms, but you should not use these features, because you may get unexpected results.)
Override: Opens a window that lists items that the current class inherits that you can select. It inserts an override definition into the selected class definition. Items listed include Properties, Methods, Parameters, Queries, SQL Triggers, and XData routines.
Rename: Enter a new name. The new name replaces the old name in all locations in the document. (Studio does not refactor code inside literal strings, such as in an embedded SQL statement or in a method that takes a string with a column name.) . If you check Reset Storage (for a class) or New Storage Slot (for a property), the renamed item is created without storage and default storage is generated. You see a confirmation box which If you choose to delete an old class, its storage extent definition is also deleted.
Refactoring delays applying changes to the database until you are finished reviewing changes across all documents. When you select Accept Changes, changes are saved in a temporary location. When you select Finish all changes are applied. If you select Finish but haven’t accepted changes to all documents, you are prompted Not all documents modified. Proceed anyway? and you can accept changes for more documents or finish.
Note: Do not use refactoring in a production environment. Use only during development. Studio does not allow any data manipulation.
Superclasses Lists superclasses of the current class alphabetically. You can pick from these to Add to Project, Show Documentation, or Open.
Derived Classes Lists classes derived from the current class (subclasses). You can pick from these to Add to Project, Show Documentation, or Open.
Create Subclass Displays the New Class Wizard. A class created using this option becomes a derived class of the class in the current window and inherits its members, including properties, methods, class parameters, applicable class keywords, and the parameters and keywords of the inherited properties and inherited methods.
A projection automatically creates related files for other languages when you compile a class. For example, adding a Projection of type %Projection.Java generates a new Java class when it compiles so that you can use your class from a Java application.
Build Menu
The Build menu contains options for compiling and building applications. The behavior of the Build options is controlled by the Compile settings in the Studio Options dialog.
The build options include:
Compile
Compiles the contents of the current window. Uses settings of the Compiler tab from Tools > Options. Any messages from the compiler are displayed in the Output Window.
  • The current class definition is only compiled if it has been modified.
  • If possible, Studio performs an incremental compile; if the only change to a class definition is in the implementation of one or more methods then only these methods are compiled.
Compile with Options Use to select options for this session only or to change the default compile options. Default options can also be set with the Tools > Options, Compiler tab
Rebuild All Compiles all the components in the current project whether or not they have been modified from the last compile.
Debug Menu
The Debug menu contains debugging options. To see the Debug Menu options, see the section Debug Menu in the chapter Using the Studio Debugging .” See also the section Keyboard Accelerators.”
Tools Menu
The Tools menu contains miscellaneous options.
The tools options include:
Class Browser Opens the Studio Class Browser. The Class Browser displays a list of all classes in the current namespace as well as their members (defined and inherited).
Show Plan for SQL Statement Opens dialog for an SQL statement. An SQL statement selected in the active document is displayed and editable in the dialog. Selecting Show Plan displays the query execution plan in a web page.
Templates
Displays a list of Studio Templates. A template injects a stream of text at the current cursor location. Studio provides templates. In addition, you can create your own. For more information see the chapter on Studio Templates.
Add-Ins Contains a list of wizards that help you add items to an open Studio file or connect to existing files using standard formats. The wizards are the .NET Gateway Wizard, the Activate Wizard, the Java Gateway Wizard, the SOAP Wizard, the XML Schema Wizard, and the XSL Transform Wizard. For more on these wizards, see the section Add-In Templates.
Task List Displays list of tasks. You can add, edit, or delete a task in the New Task window. Each task includes a server, namespace, document name, line #, and optional description. The current line code or selected text is used by default for the task description. GoTo takes you to selected document and line #. If needed, Studio connects to specified by task server/namespace using current security credentials.
Export Exports one or more items (class definitions, projects, routines, include files) to either a local file or a file on the server system.
Export Special Export RO, the format created with the %RO utility.
Import Remote
Lets you import an item from a remote file (that is; a file that is on the same machine as the server that Studio is connected to). All imported items are placed into new document windows.
You can use this option to import a project, class definition, routines, or include files from either XML, or .RTN (%RO Routine format files).
The Import Remote option displays a dialog that lists all the items contained in the file from which you can select. You can also specify whether the imported items should be added to the current project and if they should be compiled.
The hand icon indicates that the file you are importing is older than the file on the system.
Import Local
Lets you import an item from a local file (that is a file on the same machine as Studio). All imported items are placed into new document windows.
You can use this option to import a project, class definition, routines, or include files from either XML, or .RTN (%RO Routine format files).
The Import Local option displays a dialog that lists all the items contained in the file. You can select which items you want to import. You can also specify whether the imported items should be added to the current project and if they should be compiled. The list of items to import must be less than 32K.
The hand icon indicates that the file you are importing is older than the file on the system.
Compare Compares an open file to one that you select with Browse. You must have specified an external compare tool with the Compare setting in Options > Environment > General. To work correctly, the compare tool must be able to accept command line parameters as tool.exe file1 file2. Tested compare tools are Microsoft Windiff and Perforce p4Diff.exe.
Copy Class Creates a copy of an existing class with a new name.
Generate C++ Projection Creates C++-related files when this class is compiled so you can use this class from a C++ application. For more information, see the chapter Using the C++ Binding in the book Using C++ with Caché.
Import and Export Settings Opens Import and Export Studio settings wizard. In this wizard you can set file and directory for import and export and save these settings to a text file in format compatible with regedit.exe. This file can be imported by wizard or executed directly from command prompt or explorer on any windows computer. Import and reset settings cause a Studio restart. Import on Windows Vista requires administrator privileges to run.
Options
Lets you set Studio options. For details on options see the chapter Studio Options.”
Customize Opens Customize window, in which you can customize aspects of the Studio UI, such as menus and toolbars.
Utilities Menu
The Utilities menu contains links to resources outside of Studio, such as:
Window Menu
The Window menu contains standard window options for manipulating the windows in Studio.
Help Menu
The Help menu contains options for accessing online Help.
The help options include:
Studio Documentation Displays the table of contents for Studio documentation.
Studio Commands Displays the list of Studio options and short descriptions.
Online Documentation Displays the home page of the Caché Online Documentation.
ObjectScript Reference Displays the ObjectScript online reference.
SQL Reference Displays the Caché SQL online reference.
Class Definition Syntax Displays the online reference for class definition syntax.
InterSystems on the Web Provides links to useful pages on the InterSystems Web Site.
About Studio Displays version information about Studio.
Context Menus
Right-clicking areas in Studio displays different context menu. These include those described in the following sections.
Editor Context Menu
Right-clicking in the Studio Editor window displays a context menu. Within this context menu are many items available from the main menus, such as on the Editor menu are Cut, Copy, Paste, Find, Toggle Breakpoint, and Go Back, and so on. There are also additional options that are not available from the main menu. These include:
Help
The Help option displays context-sensitive help for selected syntactical elements. To use, right-click text and select Help.
For example, if you right-click the word Do in ObjectScript code and select Help , the reference page for the Do command is displayed in your browser.
Add Task Opens the Add Task window, in which you can add a task to the task list. See also Tools Menu.
Set Syntax Color
Displays a dialog in which you can choose the color used to display a specific syntactical element.
To use, right-click text and select Set Syntax Color.
Goto <TAG>
Available when editing an ObjectScript routine. Lets you jump to the code that defines the ObjectScript tag.
To use, in an ObjectScript routine, right-click a tag and select Goto <TAG> . If the right-clicked tag is defined in another routine, Studio automatically opens this routine.
Set current item as debug target Sets the current item as the debug target.
Toggle Word Highlight Highlights all instances of the word the cursor is pointing to in the document .
Workspace Context Menu
Right-clicking the Workspace window displays a context menu. Which menu is displayed depends on the cursor location. Different context menus are displayed if the cursor is on a package, a class, a CSP file, and so on. This table below shows items on the Workspace Package context menu not available on the menu bar.
Add Adds a class selected from the displayed list to the current package.
Remove Package “name” Removes the current package from this project.
Compile Package “name” Compiles the current package.
Delete Package “name” Deletes the current package.
Export Exports the current package to an xml file. (To import a package, select Tools > Import and select an xml file.)
Add to Project Adds the highlighted item to the current project.
Source Control Select from Source Control options Check Out, Undo Checkout, Check In, Get Latest
For more information see the section on Source Control Hooks.
Close Closes the current document.
Close All But This Closes all documents except the highlighted document.
Close All Closes all documents.
Inspector Context Menu
Right-clicking the Inspector window displays a context menu with the following items (if they are applicable to the current document in the editor window):
Add Adds a member selected from the displayed list to the current class definition.
Override Opens a window that lists items inherited by the current class, from which you select. An override definition is inserted into the current class definition window.
Reset to Default Resets selected item to default.
Delete Deletes the displayed item.
Locate Available when a class member is displayed. Displays the member in the editor window.
Show Inherited Members Toggles the inclusion of inherited members in the window display.
Show Headers Toggles the display of the column headers, Name and Value, in the Inspector window.
Tab Context Menu
Right-clicking the tabs header displays a context menu with these items:
Close Closes the current tab.
Close All But This Closes all tabs except the current tab.
Close All Closes all tabs.
Window Display Context Menu
Right-clicking a window where no other context menus apply shows the generic window context menu:
Floating Disconnects the selected window from a fixed location; that is, it can be dragged freely to a desired locaiton.
Docking Glues the selected window to a default location.
Hide Conceals the selected window.
Debugger Watch Context Menu
To see the Debugger Watch Window Context Menu, see the section Debugger Watch Context Menu in the chapter Using the Studio Debugger in this book.
Keyboard Accelerators
This section lists Studio's keyboard accelerators (keyboard shortcuts)—combinations of keys that, when pressed, perform a Studio function. These are listed in the following table.
block of text
In the following table a block of text means a number of whole lines. To select a block of text, put the caret at the start of the first line, press Shift, and select the down arrow till all of the relevant lines are highlighted. The caret is then displayed at the start of the line beneath the last whole line.
Accelerator Action
General
F1 Context Help
F4 Change Namespace or Connection
F8 Toggles Full Screen Display of Studio menus and editor window.
Ctrl+N New Document
Ctrl+O Open Document
Ctrl+Shift+O Open Project
Ctrl+P
Print
Opens the Print dialog. If text is selected, Selection is checked.
Ctrl+S Save
Ctrl+Shift+I Export
Ctrl+I Import Local
Display
Ctrl++
Expand All
Expands all sections in the document that can be expanded.
Select minus icon to collapse a section or Ctrl+- to collapse all sections.
Ctrl+Left Select plus icon
Expand All Block Sections
Expands all sections in this code block that can be expanded.
Select minus icon to collapse a block or Ctrl+- to collapse all blocks.
Ctrl+-
Collapse All
Collapses all sections that can be collapsed.
Ctrl+W Show Class Browser
Ctrl+Shift+V
View Other
Opens documents related to the current document, such as MAC or INT routines.
Alt+1 Toggles Inspector window display
Alt+2
Toggles Output window display
The Output window has tabs for Result and Find in Files.
Alt+3 Toggles Workspace window display
Alt+4 Toggles Watch window display
Alt+5 Toggles Code Snippets window display
Alt+6 Toggles Find in Files window display
Alt+7 Toggles Class View window display
Ctrl+Alt++
Increase Font
(Press Ctrl and Alt and the equal sign key — here called the plus sign.)
Ctrl+Alt+-
Decrease Font
(Press Ctrl and Alt and the minus key.)
Ctrl+Alt+Space Toggles display of Whitespace Symbols, spaces, newlines, and tabs
Ctrl+B
Toggle Bracket Matching
Turns bracket matching on and off for the current window.
Ctrl+Shift+N Toggles Line Numbers Display.
Ctrl+Tab Next Window
Ctrl+Shift+Tab Previous Window
Navigation
Home
Go To Beginning of Line
Subsequent presses hops the caret between the beginning of the line and the beginning of text on the line.
Ctrl+Home Go To Beginning of Document
End Go To End of Line
Ctrl+End Go To End of Document
Ctrl+- Back
Ctrl+Shift+- Forward
Page Up Page Up
Page Down Page Down
Ctrl+Page Up Go To Top of Visible Page
Ctrl+Page Down Go To Bottom of Visible Page
Ctrl+↓ Scroll Down
Ctrl+↑ Scroll Up
Ctrl+G Goto
Ctrl+Shift+G or F12 Goto Documentation for Tag
Ctrl+F3 Go To Next Error
Ctrl+Shift+F3 Go To Previous Error
Alt+F3 Go to Next Warning
Alt+Shift+F3 Go to Previous Warning
Ctrl+]
Go To Bracket
Moves the cursor between the innermost pair of brackets (or parentheses or braces). Pairs of all three kinds (one of each) can be highlighted if they are nested. This accelerator works only if bracket matching is turned on (see Ctrl+B).
Editing
Insert
Toggle Insert/Overwrite Mode
Toggles between Insert mode (new characters are inserted when typing) and Overwrite mode (new characters replace existing characters when typing).
Ctrl+Delete
Delete Next Word or to End of Word
If caret is at the start of a word, deletes the word. If caret is in the middle of a word, deletes from the caret to the end of word.
Ctrl+Backspace or Ctrl+Shift+Delete
Delete Previous Word or to Start of Word
If the caret is at the end of a word, deletes the word. If caret is in the middle of a word, deletes from caret to start of word.
Ctrl+Shift+L Delete Line
Ctrl+C or Ctrl+Insert Copy
Shift+Delete or Ctrl+X Cut
Ctrl+L Cut Line
Ctrl+V or Shift+Insert Paste
Ctrl+A Select All
Ctrl+Y or Ctrl+Shift+Z Redo
Ctrl+Z Undo
Ctrl+Space
Show Popup
If the cursor is in an appropriate location, this displays the Studio Assist popup, which shows options available for this location (such as classes, methods, properties, and so on, as appropriate).
Ctrl+~
Toggle Tab Expansion
Toggles whether tabs or spaces are entered when you press Tab.
Ctrl+U Uppercase Selection
Ctrl+Shift+U Lowercase Selection
Ctrl+Alt+O Toggles the Delay Parsing option.
Ctrl+Alt+U Titlecase (Initial Caps) Selection
Ctrl+( Insert Open and Close Parentheses. (Does not work on German and Swiss keyboards.*)
Ctrl+{ Insert Open and Close Braces.
Ctrl+[ Insert Open and Close Square Brackets.
Ctrl+< Inserts Open and Close Angle Brackets.
Ctrl+= Indentation Cleanup. Cleans up indentation on a selected block of whole lines of text.
Ctrl+/
Comment Line
Turns a selected line into a comment by adding a # (pound sign) to the beginning of the line.
Ctrl+Shift+/
Uncomment Line
Turns a selected comment into a regular line by removing a # (pound sign) from the beginning of the line.
Ctrl+/
Comment Block of Text
Pressing Ctrl+/ while a block of text is selected comments the block of text; that is, adds #; (pound semi-colon) to the start of each line (for Objectscript routine) or appropriate marker based on the document’s language. (Does not work on German and Swiss keyboards.*)
Ctrl+Shift+/
Uncomment Block of Text
Pressing Ctrl+Shift+/ while a block of text is selected uncomments the block of text (that is, removes the #; from the start of each line for Objectscript routine — or other marker based on the document’s language). (Does not work on German and Swiss keyboards.*)
Ctrl+Alt+/
Comment Markers Added to Block of Text
Inserts block type comments (such as /*...*/) for specific language if block comments are supported. If block type comments do not exist, then single line comment marker is inserted. (Does not work on German and Swiss keyboards.*)
Ctrl+Shift+Alt+/
Comment Markers Removed from Block of Text
Removes block type comments (such as /*...*/) for specific language if block comments are supported. If block type comments do not exist, then single line comment marker is inserted. (Does not work on German and Swiss keyboards.*)
Ctrl+E In an ObjectScript document, commands in a selection are replaced with their full names.
Ctrl+Shift+E
Compress Commands
In an ObjectScript document, commands in a selection are replaced with their abbreviated names.
Ctrl+.
Insert Dots
With a block of text selected, Insert dots at the start of each line (after leading white space). Lines must start with leading whitespace. This is for use in block structuring with leading periods with argumentless DO commands.
Ctrl+Shift+.
Remove Dots
Remove leading dots from the start of the selected block of text (for use in block structuring with leading periods with argumentless DO commands).
Ctrl+Shift+T
Add Task
Find and Replace
Ctrl+F Find
F3 Find Next
Shift+F3 Find Previous
Ctrl+Shift+F Find in Files
Ctrl+, (comma) Search
Ctrl+H Replace
Ctrl+Shift+G Go To
Ctrl+Alt+G Go Back
Bookmarks
Ctrl+F2 Toggle Bookmark on Current Line
F2 Go to Next Bookmark
Shift+F2 Go to Previous Bookmark
Ctrl+Shift+F2 Clear All Bookmarks
Build and Compile
F7 Rebuilds All Documents in Project
Ctrl+F7 Compile Active Document
Ctrl+Shift+F7 Compile with Options
F5 View as Web Page
Debugging
Ctrl+Alt+L
Toggle Studio Debug Logging
Turns logging on or off. If on, information is sent to the file /cacheinstall/bin/CD###.log for Studio debugging purposes. This file can become very large. Use carefully. For details, see Logging in Using Caché Direct.
Ctrl+Shift+A
Debug Attach
Attach the debugger to a process.
F9 Debug Toggle Breakpoint on Current Line
Ctrl+F5 Debug Start
Ctrl+Shift+F5 Debug Restart
Ctrl+F10
Debug Run to Cursor
Resumes program execution and pauses at the cursor line or a breakpoint.
F11
Debug Step Into
From a break or an interrupt, step into the next loop.
Shift+F11
Debug Step Out
Step out of the current process.
F10
Debug Step Over
Skip over the next process.
Shift+F5 Debug Stop
Templates
Ctrl+Shift+1 - Ctrl+Shift+9
Open Template
Can be used as accelerators for Studio Templates. To set an accelerator, add an attribute in the form accelerator="#" to the template (in either the csp:StudioInteractiveTemplate tag or the csp:StudioSimpleTemplate tag). This sets an accelerator of Ctrl+Shift+# for the template. The number (#) can be 0-9.
Ctrl+T
Wizards: Arguments for New Method wizard and Parameters for New Query wizard
Alt+A
Add
Alt+R
Remove
Alt+U
Up
Alt+D
Down
Inserting MultiValue Characters
You can insert the following four MultiValue characters by pressing Ctrl+M and then pressing one of the characters shown in the table below.
Ctrl+M [
Insert MultiValue textmark.
Press Ctrl+M, then [.
Ctrl+M ]
Insert MultiValue subvaluemark.
Press Ctrl+M, then ].
Ctrl+M \
Insert MultiValue valuemark.
Press Ctrl+M, then \.
Ctrl+M ^
Insert MultiValue attributemark.
Press Ctrl+M, then ^.
*The German and Swiss keyboards have some different arrangements than most other keyboards. This limits some of the available keyboard accelerator combinations due to the AltGr key and the way key presses are reported in Windows.
Adding to a Studio Menu
To add a menu item to a Studio menu,
  1. In the Studio toolbar, right-click the menu name and select Customize.
  2. Select the Tools tab, add the.exe file.